angular_sentry 0.0.4

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 3

angular_sentry

Helper to implements sentry with Angular.

Usage

Basic

import "package:angular/angular.dart";
import "package:angular_sentry/angular_sentry.dart";

main() {
  bootstrap(MyApp, [
    provide(SENTRY_DSN, useValue: "MY_SENTRY_DSN"),
    provide(ExceptionHandler, useClass: AngularSentry)
  ]);
}

Advanced


main() {
  bootstrap(MyApp, [
    AppSentry
  ]);
}

@Injectable()
class AppSentry extends AngularSentry {
  AppSentry(Injector injector)
      : super(injector, "MY_SENTRY_DSN");

  SentryUser get user => new SentryUser();

  String get environment => "production";

  String get release => "1.0.0";

  Map<String, String> get extra => {"location_url": window.location.href};

  void onCatch(dynamic exception, Trace trace, [String reason]) {
    if (exception is ClientException) {
      log("Network error");
    } else {
      super.onCatch(exception, trace, reason);
    }
  }
}

Changelog

0.0.4

  • update sentry package to 1.0.0

0.0.3

  • fix logger
  • fix stacktrace parsing

0.0.2

  • Use sentry package instead of sentry_client

0.0.1

  • Initial version, created by Stagehand

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  angular_sentry: ^0.0.4

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:angular_sentry/angular_sentry.dart';
  
Version Uploaded Documentation Archive
0.0.4 Apr 16, 2018 Go to the documentation of angular_sentry 0.0.4 Download angular_sentry 0.0.4 archive
0.0.3 Apr 3, 2018 Go to the documentation of angular_sentry 0.0.3 Download angular_sentry 0.0.3 archive
0.0.2 Mar 6, 2018 Go to the documentation of angular_sentry 0.0.2 Download angular_sentry 0.0.2 archive
0.0.1 Feb 20, 2018 Go to the documentation of angular_sentry 0.0.1 Download angular_sentry 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
6
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
3
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.20.1 <2.0.0