angular_ui 0.6.13

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 25

Angular UI Build Status Stories in Ready Coverage Status

Port of Angular-UI to Dart.

Look at Demo page for this project.

You may be interesting in check out Material Design Theme for this project.

Quick-Start

Include the following code to your index.html

<!-- Latest compiled and minified bootsrap CSS -->
<link rel="stylesheet" href="https://maxcdn.bootstrapcdn.com/bootstrap/3.3.2/css/bootstrap.min.css">
<!-- Optional bootstrap theme CSS -->
<link rel="stylesheet" href="https://maxcdn.bootstrapcdn.com/bootstrap/3.3.2/css/bootstrap-theme.min.css">
<!-- angular ui CSS -->
<link rel="stylesheet" href="packages/angular_ui/css/angular.css">
<!-- your own CSS file -->
<link rel="stylesheet" href="style.css">

Add the angular-ui module in your main.dart

import 'package:angular/angular.dart';
import 'package:angular/application_factory.dart';
import 'package:angular_ui/angular_ui.dart';

void main() {
  applicationFactory()
    .addModule(new AngularUIModule()) // The angular-ui module
    .addModule(new MainModule()) // Your own module
    .run();
}

Use the angular-ui components as described below or in the demo.

##Bootstrap directives and components

  • Checkbox and RadioButton
  • DropdownToggle
  • Collapse
  • Alert
  • ProgressBar
  • Modal
  • Accordion
  • Rating
  • Datepicker (partially implemented)
  • Tabs
  • Drag and Drop support
  • Carousel
  • Timepicker
  • Pagination
  • Tooltip
  • Popover
  • Typehead

Note: Drag and Drop support is experimental feature and API can be changed at any time in the future.

##Credits

Version 0.6.13 (2016/26/09)

Bug Fixes

  • Accordion collapsed after initialization with delay #154
  • Typeahead highlight only works with the exact match need it to show highlight based on the words #171

Version 0.6.12 (2015/12/04)

Bug Fixes

  • Unit tests fail with issue: The null object does not have a method '[]'
  • Added null check when backdrop is double clicked.

Version 0.6.10-11 (2015/10/08)

Bug Fixes

  • Carousel transition canceled

Version 0.6.9, (2015/09/24)

Bug Fixes

  • Work around to tab heading issue.

Version 0.6.8, (2015/03/01)

  • Updated Copyright info.
  • Improved documentation for Carousel component and general README file

Version 0.6.7, (2015/02/27)

Bug Fixes

  • Accordion: double click on title causes inconsistent state or bad rendering
  • Accordion Collapse
  • Accordion doesn't expand after creation if is-open equals true
  • Accordion: fast clicks on title causes inconsistent state or bad rendering
  • Combine slide and angular css files

Version 0.6.0, (2014/12/12)

  • Migration on Angular Dart 1.0, support Bootstrap 3.3.1 and bug fixes.

Version 0.5.5, (2014/06/25)

Bug Fixes

  • Modal Dialog with backdrop:'static' cannot be closed by click on button with data-dismiss='modal'

Version 0.5.4, (2014/06/21)

Bug Fixes

  • Error when using typeahead-on-select=ctrl.setSelectedItem($item, $model, $label)

Version 0.5.3, (2014/06/18)

Bug Fixes

  • Typeahead placement of suggestion popover offset by 200px
  • Fix animation toggle and z-index calculation in ModalWindow

Version 0.5.2, (2014/06/17)

Features

  • Project migrated to follow Dart SDK 1.4.3

Bug Fixes

  • ModalWindow must call dismiss method of top ModalInstance instead of Modal.close.

Version 0.5.1, (2014/06/06)

Features

  • Project migrated to follow Angular Dart 0.12.0

Version 0.5.0, (2014/06/05)

Features

  • All components have migrated away from Shadow DOM and applyAuthorStyles.

Bug Fixes

  • ng-click called multiple times
  • DatePicker tests fail with UTC+1

Version 0.4.0, (2014/05/16)

Features

  • Carousel
  • Timepicker
  • Pagination
  • Tooltip
  • Popover
  • Typehead

Bug Fixes

  • Classes Popover, Tooltip, ModalWindow, DatePicker compiled to JavaScript don't work proper
  • Error compiling Pagination component to JavaScript
  • Checkbox component doesn't work proper in example

Version 0.3.0, (2014/04/19)

Features

  • Accordion
  • Datepicker (partially implemented)
  • Rating
  • Tabs
  • Drag and Drop support

Bug Fixes

  • Fixed selectors of all components
  • Fixed unittest for all components

Version 0.2.0, (2014/02/13)

Features

  • Collapse
  • DropdownToggle
  • Alert
  • Progressbar
  • Modal
  • Timeout

Bug Fixes

  • Transition and Collapse are not working as expected

Version 0.1.0, (2014/01/14)

Features

  • Buttons
  • Position
  • Transition

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  angular_ui: ^0.6.13

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:angular_ui/angular_ui.dart';
  
Version Uploaded Documentation Archive
0.6.13 Sep 26, 2016 Go to the documentation of angular_ui 0.6.13 Download angular_ui 0.6.13 archive
0.6.11 Oct 9, 2015 Go to the documentation of angular_ui 0.6.11 Download angular_ui 0.6.11 archive
0.6.10 Oct 8, 2015 Go to the documentation of angular_ui 0.6.10 Download angular_ui 0.6.10 archive
0.6.9 Sep 24, 2015 Go to the documentation of angular_ui 0.6.9 Download angular_ui 0.6.9 archive
0.6.8 Mar 1, 2015 Go to the documentation of angular_ui 0.6.8 Download angular_ui 0.6.8 archive
0.6.6 Feb 27, 2015 Go to the documentation of angular_ui 0.6.6 Download angular_ui 0.6.6 archive
0.6.5 Feb 25, 2015 Go to the documentation of angular_ui 0.6.5 Download angular_ui 0.6.5 archive
0.6.4 Feb 3, 2015 Go to the documentation of angular_ui 0.6.4 Download angular_ui 0.6.4 archive
0.6.3 Jan 16, 2015 Go to the documentation of angular_ui 0.6.3 Download angular_ui 0.6.3 archive
0.6.2 Dec 12, 2014 Go to the documentation of angular_ui 0.6.2 Download angular_ui 0.6.2 archive

All 32 versions...

Popularity:
Describes how popular the package is relative to other packages. [more]
51
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
25
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.6.0 <2.0.0