angular_youtube_iframe 0.1.3+1

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 0

angular_youtube_iframe

A Youtube player component for AngularDart (4+) based on Youtube iFrame interop

screenshot

Try the demo

<youtube-iframe [playerId]="'ytvideo'" [videoId]="videoId"
                [start]="videoStart" [end]="videoEnd"
                [width]="width" [height]="height"
                [autoPlay]="autoPlay"
                [showControls]="showControls"
                [showInfos]="showInfos"
                [disableKeyboard]="disableKeyboard"
                [modestBranding]="modestBranding"
                [mobilePlaysInline]="mobilePlaysInline"
                (onReady)="onPlayerReady($event)"
                (onError)="onError($event)"
                (onStateChange)="onStateChange($event)"
></youtube-iframe>

Changelog

0.1.3

  • components : PlayerToolbar & PlayerProgressBar
  • new player @Input : blockVideoInteraction, showRelated, playlist, list, listType...

0.1.2

  • fix the events callbacks

0.1.1

  • new @Inputs : mobilePlaysInline, modestBranding, start, end,...
  • add a currentState property
  • updated example

0.1.0

  • Initial version

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  angular_youtube_iframe: ^0.1.3+1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:angular_youtube_iframe/angular_youtube_iframe.dart';
  
Version Uploaded Documentation Archive
0.1.3+1 Oct 16, 2017 Go to the documentation of angular_youtube_iframe 0.1.3+1 Download angular_youtube_iframe 0.1.3+1 archive
0.1.3 Oct 16, 2017 Go to the documentation of angular_youtube_iframe 0.1.3 Download angular_youtube_iframe 0.1.3 archive
0.1.2 Oct 12, 2017 Go to the documentation of angular_youtube_iframe 0.1.2 Download angular_youtube_iframe 0.1.2 archive
0.1.1 Oct 12, 2017 Go to the documentation of angular_youtube_iframe 0.1.1 Download angular_youtube_iframe 0.1.1 archive
0.1.0 Oct 11, 2017 Go to the documentation of angular_youtube_iframe 0.1.0 Download angular_youtube_iframe 0.1.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.24.0 <2.0.0