angular_youtube_player 0.1.0

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 67

Angular Youtube iframe component #

Example #

<youtube-player [width]="800"
                [height]="600"
                videoId="nGlh4SVrsFg"></youtube-player>

0.1.0 #

  • Initial version, created by Stagehand

example/main.dart

import 'package:angular/angular.dart';

import 'src/app_component.dart';

Future<void> main() async {
  runApp(appNgFactory);
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  angular_youtube_player: ^0.1.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:angular_youtube_player/angular_youtube_player.dart';
  
Version Uploaded Documentation Archive
0.1.0 Feb 6, 2019 Go to the documentation of angular_youtube_player 0.1.0 Download angular_youtube_player 0.1.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
42
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
80
Overall:
Weighted score of the above. [more]
67
Learn more about scoring.

We analyzed this package on Apr 19, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.2.0
  • pana: 0.12.14

Platforms

Detected platforms: web

Primary library: package:angular_youtube_player/angular_youtube_player.dart with components: html, js.

Health suggestions

Format lib/angular_youtube_player.dart.

Run dartfmt to format lib/angular_youtube_player.dart.

Maintenance suggestions

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 <3.0.0
angular ^5.0.0 5.2.0 5.3.0
youtube_iframe_interop ^0.1.0 0.1.0
Transitive dependencies
analyzer 0.34.3 0.36.0
angular_ast 0.5.8 0.5.9
angular_compiler 0.4.2 0.4.3
args 1.5.1
async 2.2.0
build_config 0.3.2
built_collection 4.2.0
built_value 6.4.0
charcode 1.1.2
code_builder 3.2.0
collection 1.14.11
convert 2.1.1
crypto 2.0.6
csslib 0.14.6 0.15.0
dart_browser_loader 0.0.5
dart_style 1.2.3 1.2.7
fixnum 0.10.9
front_end 0.1.9+1 0.1.15
glob 1.1.7
html 0.14.0+1
intl 0.15.8
js 0.6.1+1
json_annotation 2.2.0
kernel 0.3.9+1 0.3.15
logging 0.11.3+2
matcher 0.12.5
meta 1.1.7
package_config 1.0.5
path 1.6.2
plugin 0.2.0+3
pub_semver 1.4.2
pubspec_parse 0.1.4
quiver 2.0.3
source_gen 0.9.4+1 0.9.4+2
source_span 1.5.5
stack_trace 1.9.3
string_scanner 1.0.4
term_glyph 1.1.0
typed_data 1.1.6
watcher 0.9.7+10
yaml 2.1.15
Dev dependencies
build ^1.0.0 1.1.0 1.1.3
build_runner ^1.0.0
build_test >=0.10.0 <1.0.0
build_web_compilers >=0.4.0 <1.0.0
sass_builder ^2.0.1