animation_builder 0.0.5

  • Example
  • Installing
  • Versions
  • 0


Fluent and type-safe API to build keyframes and timing for Web Animation API


A simple usage example:

void main() {
    final anim = new AnimationBuilder().duration(2000).fillForwards()
    querySelector('#output').animate(anim.makeKeyframes(), anim.makeOptions());



  • Transform methods in Keyframe and Keyframes


  • Changed style names from snake-case to camelCase
  • Added backgroundColor and color methods to Keyframes


  • Fixed Keyframes.create* clone bug


  • static method to create empty Keyframe at offset
  • Keyframes.create, Keyframes.createAt, Keyframes.createAppend, Keyframes.createAppendAt methods to create and add/append keyframes directly


  • AnimationBuilder, Keyframe, Keyframes, AnimationOptions


// Copyright (c) 2017, teja. All rights reserved. Use of this source code
// is governed by a BSD-style license that can be found in the LICENSE file.

import 'package:animation_builder/animation_builder.dart';

main() {}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  animation_builder: ^0.0.5

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:animation_builder/animation_builder.dart';
Version Uploaded Documentation Archive
0.0.5 Aug 27, 2017 Go to the documentation of animation_builder 0.0.5 Download animation_builder 0.0.5 archive
0.0.4 Aug 27, 2017 Go to the documentation of animation_builder 0.0.4 Download animation_builder 0.0.4 archive
0.0.3 Aug 27, 2017 Go to the documentation of animation_builder 0.0.3 Download animation_builder 0.0.3 archive
0.0.2 Aug 27, 2017 Go to the documentation of animation_builder 0.0.2 Download animation_builder 0.0.2 archive
0.0.1 Aug 27, 2017 Go to the documentation of animation_builder 0.0.1 Download animation_builder 0.0.1 archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see

Maintenance issues and suggestions

Running dartdoc failed. (-10 points)

Make sure dartdoc runs without any issues.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.20.1 <2.0.0