apn_fb_login 0.0.6

  • README.md
  • Example
  • Installing
  • Versions
  • 41


A flutter plugin project that allows you to easily connect to Facebook and get your profile information


iOS configuration

Edit your Info.plist and add add the following:


Don't forget to change ##APPID## and ##APPNAME##

Android configuration

Add this to your AndroidManifest.xml

    <meta-data android:name="com.facebook.sdk.ApplicationId" android:value="##APPID##"/>

Don't forget to change ##APPID##


Import the lib:

    import 'package:apn_fb_login/apn_fb_login.dart';

Define a FacebookConnect object:

    final _facebookConnect = new FacebookConnect(
        appId: '##APPID##',
        clientSecret: '##APPSECRET##'

Authenticate like so:

    ApnFbLogin.login(_facebookConnect).then((FacebookOAuthToken token) {
      this.token = token;
    }).catchError((dynamic error) {

Use the FacebookOAuthToken to get the graph/me result:

    ApnFbLogin.me().then((FacebookUser user) {
      this.user = user;
    }).catchError((dynamic error) {

See the project example for the complete example


For help getting started with Flutter, view our online documentation.

[0.0.5] -

  • [breaking] Add Facebook secret and token to AndroidManifest.xml
  • Improved automatic Facebook session creation

[0.0.4] - December 29, 2017

  • Upgraded to Gradle 4.1 and Gradle plugin 3.0.1 to match upgraded Firebase plugins

[0.0.3] - December 08, 2017

  • Fixed a NPE in the Android onActivityResult

[0.0.2] - December 03, 2017

  • Removed some unnecessary prints and files. Added url to repo

[0.0.1] - December 03, 2017

  • First release, basic auth and graph/me call to get FacebookUser.



Demonstrates how to use the apn_fb_login plugin.

Getting Started

For help getting started with Flutter, view our online documentation.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  apn_fb_login: ^0.0.6

2. Install it

You can install packages from the command line:

with Flutter:

$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:apn_fb_login/apn_fb_login.dart';
Version Uploaded Documentation Archive
0.0.6 Dec 12, 2018 Go to the documentation of apn_fb_login 0.0.6 Download apn_fb_login 0.0.6 archive
0.0.5 Dec 12, 2018 Go to the documentation of apn_fb_login 0.0.5 Download apn_fb_login 0.0.5 archive
0.0.4 Dec 29, 2017 Go to the documentation of apn_fb_login 0.0.4 Download apn_fb_login 0.0.4 archive
0.0.3 Dec 8, 2017 Go to the documentation of apn_fb_login 0.0.3 Download apn_fb_login 0.0.3 archive
0.0.2 Dec 3, 2017 Go to the documentation of apn_fb_login 0.0.2 Download apn_fb_login 0.0.2 archive
0.0.1 Dec 3, 2017 Go to the documentation of apn_fb_login 0.0.1 Download apn_fb_login 0.0.1 archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Dec 12, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.1.0
  • pana: 0.12.7
  • Flutter: 1.0.0


Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health issues and suggestions

Document public APIs (-10 points)

26 out of 26 API elements (library, class, field or method) have no adequate dartdoc content. Good documentation improves code readability and discoverability through search.

Maintenance suggestions

The description is too short. (-20 points)

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Package is pre-v0.1 release. (-10 points)

While there is nothing inherently wrong with versions of 0.0.*, it usually means that the author is still experimenting with the general direction of the API.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11
meta 1.1.6
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8