app_settings 1.0.4

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 84

app_settings #

A Flutter plugin for opening iOS and Android phone settings from an app.

Getting Started #

Include 'app_settings' from Dart Pub.

dependencies:
  flutter:
    sdk: flutter
  app_settings: 1.0.4

Next, import 'app_settings.dart' into your dart code.

import 'package:app_settings/app_settings.dart';

Platform Specifics #

The following setting options available on both iOS and Android: openWIFISettings, openLocationSettings, openSecuritySettings

iOS #

All three options open the current 'app' settings section if there are settings defined. If no current settings are defined for the app the iPhone Settings Screen will be displayed.

Android #

Each option will open and display the exact corresponding screen: WIFI, Location, or Security.

Example #

Example implementation using a raised button 'onPressed' event.

Widget build(BuildContext context) {
    return Row(
        children: <Widget>[
            RaisedButton(
                onPressed: AppSettings.openLocationSettings(),
                child: Text('Open Location Settings'),
            ),
        ],
    );
}

1.0.2 #

Platform Specifics #

The following setting options available on both iOS and Android: openWIFISettings, openLocationSettings, openSecuritySettings.

iOS #

All three options open the current 'app' settings section if there are settings defined. If no current settings are defined for the app the iPhone Settings Screen will be displayed.

Android #

Each option will open and display the corresponding screen: WIFI, Location, or Security.

1.0.3 #

Adding additional documentation.

1.0.4 #

Upgrading Kotlin version from: ext.kotlin_version = '1.2.71' to ext.kotlin_version = '1.3.20'

example/README.md

app_settings #

A Flutter plugin for opening iOS and Android phone settings from an app.

Getting Started #

Include 'app_settings' from Dart Pub.

dependencies:
  flutter:
    sdk: flutter
  app_settings: 1.0.3

Next, import 'app_settings.dart' into your dart code.

import 'package:app_settings/app_settings.dart';

Platform Specifics #

The following setting options available on both iOS and Android: openWIFISettings, openLocationSettings, openSecuritySettings

iOS #

All three options open the current 'app' settings section if there are settings defined. If no current settings are defined for the app the iPhone Settings Screen will be displayed.

Android #

Each option will open and display the exact corresponding screen: WIFI, Location, or Security.

Example #

Example implementation using a raised button 'onPressed' event.

Widget build(BuildContext context) {
    return Row(
        children: <Widget>[
            RaisedButton(
                onPressed: AppSettings.openLocationSettings(),
                child: Text('Open Location Settings'),
            ),
        ],
    );
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  app_settings: ^1.0.4

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:app_settings/app_settings.dart';
  
Version Uploaded Documentation Archive
1.0.4 Jan 30, 2019 Go to the documentation of app_settings 1.0.4 Download app_settings 1.0.4 archive
1.0.3 Jan 18, 2019 Go to the documentation of app_settings 1.0.3 Download app_settings 1.0.3 archive
1.0.2 Jan 18, 2019 Go to the documentation of app_settings 1.0.2 Download app_settings 1.0.2 archive
1.0.1 Jan 18, 2019 Go to the documentation of app_settings 1.0.1 Download app_settings 1.0.1 archive
1.0.0 Jan 18, 2019 Go to the documentation of app_settings 1.0.0 Download app_settings 1.0.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
68
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
84
Learn more about scoring.

We analyzed this package on Feb 20, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.1.0
  • pana: 0.12.13+1
  • Flutter: 1.2.1

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11
meta 1.1.6 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8