app_usage 0.0.3

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 62

app_usage #

pub package

Install #

Add app_usage as a dependency in pubspec.yaml. For help on adding as a dependency, view the documentation.

Android #

NB: Requires API level 21 as a minimum!

You need to add the following package to the manifest namespace in AndroidManifest.xml:

xmlns:tools="http://schemas.android.com/tools"

as well as the following permissions to the manifest:

    <uses-permission
        android:name="android.permission.PACKAGE_USAGE_STATS"
        tools:ignore="ProtectedPermissions" />

Below is an example of how the start of your manifest should look in the end

<manifest xmlns:android="http://schemas.android.com/apk/res/android"
    package="YOUR_PACKAGE_NAME_HERE"
    xmlns:tools="http://schemas.android.com/tools">

    <uses-permission
        android:name="android.permission.PACKAGE_USAGE_STATS"
        tools:ignore="ProtectedPermissions"/>

Usage #

void function() async {
  // Initialization
  AppUsage appUsage = new AppUsage();
  
  // Define a time interval
  DateTime endDate = new DateTime.now();
  DateTime startDate = DateTime(endDate.year, endDate.month, endDate.day, 0, 0, 0);
  
  // Fetch the usage stats
  Map<String, double> usage = await appUsage.getUsage(startDate, endDate);
}

Example #

The first screen will ask for permission to view usage stats. Tap on your application. Screen 1

Tap on the 'Permit usage access' switch. Screen 2

Your application is now running, if the manifest has been corectly set up you should be presented with the following screen after tapping the refresh button. Screen 3

0.0.1 #

  • TODO: Describe initial release.

example/README.md

app_usage_example #

Demonstrates how to use the app_usage plugin.

Getting Started #

For help getting started with Flutter, view our online documentation.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  app_usage: ^0.0.3

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:app_usage/app_usage.dart';
  
Version Uploaded Documentation Archive
0.0.3 Feb 13, 2019 Go to the documentation of app_usage 0.0.3 Download app_usage 0.0.3 archive
0.0.2 Nov 19, 2018 Go to the documentation of app_usage 0.0.2 Download app_usage 0.0.2 archive
0.0.1 Nov 19, 2018 Go to the documentation of app_usage 0.0.1 Download app_usage 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
29
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
90
Overall:
Weighted score of the above. [more]
62
Learn more about scoring.

We analyzed this package on Feb 20, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.1.0
  • pana: 0.12.13+1
  • Flutter: 1.2.1

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health issues and suggestions

Document public APIs. (-1 points)

4 out of 4 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Maintenance suggestions

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11
meta 1.1.6 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8