A dart transformer to generate an appcache manifest file
This transformer generates an appcache manifest file with all the project resources and modifies the entry points to reference it. The appcache manifest is only generated in release mode
0.1.2 Added support for caching files in lib folder
Add the transformer to your pubspec.yaml:
transformers: - appcache: $exclude: ["**.dart"] entry_points: web/index.html cache: - web/index.html_bootstrap.dart.js
(Assuming you already added this package to your pubspec.yaml file.)
transformers: - appcache: $exclude: ["file1", "dir1", "**.dart"] entry_points: web/index.html
transformers: - appcache: entry_points: web/index.html cache: - web/index.html_bootstrap.dart.js - web/packages/web_components/webcomponents.min.js - web/packages/web_components/dart_support.js - web/packages/polymer/src/js/polymer/polymer.min.js - https://ajax.googleapis.com/ajax/libs/webfont/1.4.7/webfont.js
transformers: - appcache: entry_points: web/index.html network: - web/file1 - web/file2
transformers: - appcache: entry_points: web/index.html fallback: - / web/offine.html
Add this to your package's pubspec.yaml file:
dependencies: appcache: ^0.1.4
You can install packages from the command line:
$ pub get
Alternatively, your editor might support
Check the docs for your editor to learn more.
Now in your Dart code, you can use:
|0.1.4||Oct 28, 2016|
|0.1.3||Oct 27, 2016|
|0.1.2||Apr 9, 2015|
|0.1.1||Jan 5, 2015|
|0.1.0||Jan 5, 2015|
|0.0.3||Jan 5, 2015|
|0.0.2||Jan 5, 2015|
|0.0.1||Jan 4, 2015|
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.
Fix dependencies in
pub upgrade failed with the following output:
ERR: The current Dart SDK version is 2.1.0. Because appcache depends on code_transformers any which requires SDK version >=1.0.0 <2.0.0, version solving failed.
dartfmt to format
Add SDK constraint in
pubspec.yaml. (-50 points)
For information about setting SDK constraint, please see https://www.dartlang.org/tools/pub/pubspec#sdk-constraints.
Fix platform conflicts. (-20 points)
Error(s) prevent platform classification:
Fix dependencies in
dartdoc failed. (-10 points)
dartdoc runs without any issues.
Package is too old. (-100 points)
The package was released more than two years ago.
CHANGELOG.md. (-20 points)
Changelog entries help clients to follow the progress in your code.
The description is too short. (-20 points)
Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.
Maintain an example. (-10 points)
Create a short demo in the
example/ directory to show how to use this package. Common file name patterns include:
example.dart or you could also use