aqueduct_test 1.0.0+1

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 86

Test framework for aqueduct applications. This package is included as a dev_dependency of aqueduct applications.

The documentation for this package is available at https://aqueduct.io/docs/testing/.

1.0.0+1

  • Bumps some dependency constraints to be more permissive

1.0.0

  • Initial version from package:aqueduct.
  • Adds TestHarness base class for test harnesses.
  • Adds TestHarnessORMMixin for testing ORM applications.
  • Adds TestHarnessAuthMixin for testing OAuth2 applications.
  • Renames TestClient to Agent and adds methods for executing requests without constructing a TestRequest.
  • Adds default parameters to Agent for its requests.

example/main.dart

import 'package:aqueduct_test/aqueduct_test.dart';
import 'package:aqueduct/aqueduct.dart';
import 'package:test/test.dart';

void main() {
  final harness = TestHarness<App>()..install();

  test("GET /example returns simple map", () async {
    final response = await harness.agent.get("/example");
    expectResponse(response, 200, body: {"key": "value"});
  });
}

class App extends ApplicationChannel {
  @override
  Controller get entryPoint {
    final router = Router();
    router.route("/example").linkFunction((req) async => Response.ok({"key": "value"}));
    return router;
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  aqueduct_test: ^1.0.0+1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:aqueduct_test/aqueduct_test.dart';
  
Version Uploaded Documentation Archive
1.0.0+1 Nov 15, 2018 Go to the documentation of aqueduct_test 1.0.0+1 Download aqueduct_test 1.0.0+1 archive
1.0.0 Aug 6, 2018 Go to the documentation of aqueduct_test 1.0.0 Download aqueduct_test 1.0.0 archive
1.0.0-beta.2 Jul 24, 2018 Go to the documentation of aqueduct_test 1.0.0-beta.2 Download aqueduct_test 1.0.0-beta.2 archive
1.0.0-beta.1 Jul 22, 2018 Go to the documentation of aqueduct_test 1.0.0-beta.1 Download aqueduct_test 1.0.0-beta.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
72
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
86
Learn more about scoring.

We analyzed this package on Dec 5, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.1.0
  • pana: 0.12.7

Platforms

Detected platforms: other

Primary library: package:aqueduct_test/aqueduct_test.dart with components: io, isolate, mirrors.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 <3.0.0
aqueduct ^3.0.0 3.0.2 3.1.0-beta.1
matcher >=0.12.3 <0.14.0 0.12.3+1 0.12.4
test ^1.3.0 1.5.1+1
Transitive dependencies
analyzer 0.32.6 0.34.0
args 1.5.1
async 2.0.8
boolean_selector 1.0.4
charcode 1.1.2
codable 1.0.0
collection 1.14.11
convert 2.0.2
crypto 2.0.6
csslib 0.14.6
front_end 0.1.4+2 0.1.7
glob 1.1.7
html 0.13.3+3
http 0.12.0
http_multi_server 2.0.5
http_parser 3.1.3
io 0.3.3
isolate_executor 2.0.2
js 0.6.1+1
json_rpc_2 2.0.9
kernel 0.3.4+2 0.3.7
logging 0.11.3+2
meta 1.1.6
mime 0.9.6+2
multi_server_socket 1.0.2
node_preamble 1.4.4
open_api 2.0.1
package_config 1.0.5
package_resolver 1.0.6
password_hash 2.0.0
path 1.6.2
plugin 0.2.0+3
pool 1.3.6
postgres 1.0.2
pub_cache 0.2.2
pub_semver 1.4.2
safe_config 2.0.1
shelf 0.7.3+3
shelf_packages_handler 1.0.4
shelf_static 0.2.8
shelf_web_socket 0.2.2+4
source_map_stack_trace 1.1.5
source_maps 0.10.8
source_span 1.4.1
stack_trace 1.9.3
stream_channel 1.6.8
string_scanner 1.0.4
term_glyph 1.0.1
test_api 0.2.1
test_core 0.2.0+1
typed_data 1.1.6
utf 0.9.0+5
vm_service_client 0.2.6
watcher 0.9.7+10
web_socket_channel 1.0.9
yaml 2.1.15