arm7_tdmi 0.0.1-dev+2

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 0

arm7_tdmi

An emulator for the ARM7/TDMI processor.

Pub Build Status Coverage Status documentation

This project is primarily academic/educational, and prefers idiomatic Dart and readability over performance. After completion it should be executable on any major platform, including the web, standalone VM, and Flutter.

Progress

WARNING: Largely incomplete and not ready for use.

Goals (subject to change):

  • [ ] Be able to run (emulated) programs compiled for the ARM7/TDMI
  • [ ] A web and command-line interface for testing/debugging compiled programs
  • [ ] Use in other emulator projects (educational only)
  • [ ] An end-to-end example of a large/complex cross-platform library for Dart
  • [ ] A test suite for others to write their own processor implementations

Learning more about the ARM7/TDMI

Notable uses of this processor include:

  • Microsoft Zune HD
  • Nintendo DS
  • Nintendo GameBoy Advance
  • Nokia 6110
  • Sega Dreamcast

If you're interested in learning more about this processor read the dartdocs in this package or you can view various collected PDFS and documents on the topic in the main repository - github.com/matanlurey/gba.dart.

There is no guaranteed API stability at this time. Use at your own risk.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  arm7_tdmi: ^0.0.1-dev+2

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:arm7_tdmi/arm7_tdmi.dart';
  
Version Uploaded Documentation Archive
0.0.1-dev+2 Feb 12, 2017 Go to the documentation of arm7_tdmi 0.0.1-dev+2 Download arm7_tdmi 0.0.1-dev+2 archive
0.0.1-dev Feb 6, 2017 Go to the documentation of arm7_tdmi 0.0.1-dev Download arm7_tdmi 0.0.1-dev archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.21.0-dev.2.0 <2.0.0