aspen_assets 0.2.0

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 24

aspen_assets

Access assets packed via Aspen. See the Aspen documentation for more details.

development

0.2.0

  • Ensure assets are never globally loaded twice.

0.1.1

  • Fix a decoding bug in the CSS loader.

0.1.0

Initial.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  aspen_assets: ^0.2.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:aspen_assets/aspen_assets.dart';
  
Version Uploaded Documentation Archive
0.2.0 Dec 11, 2017 Go to the documentation of aspen_assets 0.2.0 Download aspen_assets 0.2.0 archive
0.1.1 Nov 20, 2017 Go to the documentation of aspen_assets 0.1.1 Download aspen_assets 0.1.1 archive
0.1.0 Nov 18, 2017 Go to the documentation of aspen_assets 0.1.0 Download aspen_assets 0.1.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
47
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
24
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.8.0 <2.0.0