assortment 0.1.4

  • README.md
  • Installing
  • Versions
  • 3

Assortment

Simple sortable DOM elements in Dart using HTML5 drag and drop

Usage

To use this library in your code :

  • add a dependency in your pubspec.yaml :
dependencies:
  assortment: ">=0.1.0 <1.0.0"
  • add import in your dart code :
import 'package:assortment/assortment.dart';
  • create an Assortment within an element
var a = new Assortment(querySelector('#sortable-container'));
  • add children to the Assortment
a.addElements(querySelectorAll('#sortable-container .sortable-entry'));
  • rearrange elements by dragging and dropping

  • listen for events to run code during drags

a.onDragEnter.listen((AssortmentEvent event) {
  // update model
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  assortment: ^0.1.4

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:assortment/assortment.dart';
  
Version Uploaded Documentation Archive
0.1.4 Feb 8, 2017 Go to the documentation of assortment 0.1.4 Download assortment 0.1.4 archive
0.1.3 Feb 24, 2016 Go to the documentation of assortment 0.1.3 Download assortment 0.1.3 archive
0.1.2 Nov 24, 2013 Go to the documentation of assortment 0.1.2 Download assortment 0.1.2 archive
0.1.1 Oct 29, 2013 Go to the documentation of assortment 0.1.1 Download assortment 0.1.1 archive
0.1.0 Oct 29, 2013 Go to the documentation of assortment 0.1.0 Download assortment 0.1.0 archive
0.1.3-dev Feb 24, 2016 Go to the documentation of assortment 0.1.3-dev Download assortment 0.1.3-dev archive
Popularity:
Describes how popular the package is relative to other packages. [more]
5
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
3
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Maintenance issues and suggestions

Running dartdoc failed. (-10 points)

Make sure dartdoc runs without any issues.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=0.8.10+6 <2.0.0