async_util 0.1.1

  • Installing
  • Versions
  • 0


Utility classes and functions to make async operations with dart easier.

Pull requests are welcome!


A class for limiting the number of async tasks that are pending in the async queue at a given time.

// Only allow a single task to be pending in the async queue.
final limiter = new Limiter(1);
// Task 1
limiter.execute(() async => await new Future(() => print('Guaranteed to run first')));
// Task 2
limiter.execute(() => print('Guaranteed to run second'));

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  async_util: ^0.1.1

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:async_util/async_util.dart';
Version Uploaded Documentation Archive
0.1.1 Aug 12, 2016 Go to the documentation of async_util 0.1.1 Download async_util 0.1.1 archive
0.1.0 Aug 12, 2016 Go to the documentation of async_util 0.1.0 Download async_util 0.1.0 archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see

Maintenance issues and suggestions

Running dartdoc failed. (-10 points)

Make sure dartdoc runs without any issues.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.0.0 <2.0.0