async_util 0.1.1

  • README.md
  • Installing
  • Versions
  • 33

async_util

Utility classes and functions to make async operations with dart easier.

Pull requests are welcome!

Limiter

A class for limiting the number of async tasks that are pending in the async queue at a given time.

// Only allow a single task to be pending in the async queue.
final limiter = new Limiter(1);
// Task 1
limiter.execute(() async => await new Future(() => print('Guaranteed to run first')));
// Task 2
limiter.execute(() => print('Guaranteed to run second'));

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  async_util: "^0.1.1"

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:async_util/async_util.dart';
        
Version Uploaded Documentation Archive
0.1.1 Aug 12, 2016 Go to the documentation of async_util 0.1.1 Download async_util 0.1.1 archive
0.1.0 Aug 12, 2016 Go to the documentation of async_util 0.1.0 Download async_util 0.1.0 archive

Analysis

We analyzed this package on Apr 23, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0-dev.49.0
  • pana: 0.10.6

Scores

Popularity:
Describes how popular the package is relative to other packages. [more]
0 / 100
Health:
Code health derived from static analysis. [more]
94 / 100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
24 / 100
Overall score:
Weighted score of the above. [more]
33
Learn more about scoring.

Platforms

Detected platforms: Flutter, web, other

No platform restriction found in primary library package:async_util/async_util.dart.

Suggestions

  • Maintain CHANGELOG.md.

    Changelog entries help clients to follow the progress in your code.

  • Package is pre-v1 release.

    While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction API.

  • Maintain an example.

    Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use async_util.dart.

  • Fix analysis and formatting issues.

    Analysis or formatting checks reported 2 hints.

    Run dartfmt to format lib/async_util.dart.

    Run dartfmt to format lib/src/limiter.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.0.0 <2.0.0
Dev dependencies
test ^0.12.13+4