atlassian_connect_models 0.0.3

  • Installing
  • Versions
  • 25


A library for Dart developers. It is awesome.


A simple usage example:

import 'package:atlassian_connect_models/atlassian_connect_models.dart';

main() {
  var awesome = new Awesome();

Features and bugs

Please file feature requests and bugs at the issue tracker.



  • Initial version, created by Stagehand

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  atlassian_connect_models: "^0.0.3"

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

      import 'package:atlassian_connect_models/atlassian_connect_models.dart';
Version Uploaded Documentation Archive
0.0.3 Apr 10, 2016 Go to the documentation of atlassian_connect_models 0.0.3 Download atlassian_connect_models 0.0.3 archive
0.0.2 Mar 11, 2016 Go to the documentation of atlassian_connect_models 0.0.2 Download atlassian_connect_models 0.0.2 archive
0.0.1 Mar 11, 2016 Go to the documentation of atlassian_connect_models 0.0.1 Download atlassian_connect_models 0.0.1 archive


We analyzed this package on May 22, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0-dev.54.0
  • pana: 0.11.1


Describes how popular the package is relative to other packages. [more]
0 / 100
Code health derived from static analysis. [more]
82 / 100
Reflects how tidy and up-to-date the package is. [more]
0 / 100
Overall score:
Weighted score of the above. [more]
Learn more about scoring.


Detected platforms: Flutter, web, other

No platform restriction found in primary library package:atlassian_connect_models/atlassian_connect_models.dart.


  • Fix analysis and formatting issues.

    Analysis or formatting checks reported 10 errors 7 hints.

    Strong-mode analysis of lib/src/descriptor/bitbucket/webhooks.dart failed with the following error:

    line: 62 col: 7
    The redirected constructor '(Map<String, Object>) → _BitbucketPRWebHookEvent' has incompatible parameters with '(Map<dynamic, dynamic>) → BitbucketPRWebHookEvent'.

    Strong-mode analysis of lib/src/descriptor/confluence/webhooks.dart failed with the following error:

    line: 56 col: 7
    The redirected constructor '(Map<String, Object>) → _ConfluenceWebHookEvent' has incompatible parameters with '(Map<dynamic, dynamic>) → ConfluenceWebHookEvent'.

    Similar analysis of the following files failed:

    • lib/src/descriptor/descriptor_model.dart (error)
    • lib/src/descriptor/hipchat/hipchat_descriptor_model.dart (error)
    • lib/src/descriptor/jira/webhooks.dart (error)
    • lib/src/descriptor/bitbucket/bitbucket_descriptor_model.dart (hint)
    • lib/src/descriptor/bitbucket/scopes.dart (hint)
    • lib/src/descriptor/confluence/confluence_descriptor_model.dart (hint)
    • lib/src/descriptor/jira/jira_descriptor_model.dart (hint)
    • lib/src/event/host_event_model.dart (hint)
    • lib/src/event/host_model.dart (hint)
  • The description is too short.

    Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

  • Package is pre-v1 release.

    While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction API.

  • Maintain an example.

    Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use atlassian_connect_models.dart.

  • Use analysis_options.yaml.

    Rename old .analysis_options file to analysis_options.yaml.

  • Enable strong mode analysis.

    Strong mode helps you to detect bugs and potential issues earlier.Start your analysis_options.yaml file with the following:

      strong-mode: true


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.9.0 <2.0.0
constrain ^0.2.8 0.2.8
option ^1.1.0 1.2.0
quiver >=0.20.0 <0.22.0 0.21.4 0.29.0+1
stuff ^0.0.6 0.0.7
uri >=0.9.3 <0.12.0 0.11.2
Transitive dependencies
collection 1.14.9
concepts 0.2.0
either 0.1.8
matcher 0.12.2+1
path 1.3.9 1.5.1
stack_trace 1.9.2
utf 0.9.0+4
Dev dependencies
test >=0.12.0 <0.13.0