atonline_api 0.0.4

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • new64

atonline_flutter

AtOnline API tools for Flutter

Purpose

This package allows simple access to AtOnline APIs, such as user accounts (oauth2), and all the services provided by AtOnline.

[0.0.3] - January 1st 2019

  • Fix links API to handle query string in links correctly

[0.0.1] - December 29th 2018

  • Initial release with API, user & links code.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  atonline_api: ^0.0.4

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:atonline_api/atonline_api.dart';
  
Version Uploaded Documentation Archive
0.0.4 Jan 5, 2019 Go to the documentation of atonline_api 0.0.4 Download atonline_api 0.0.4 archive
0.0.3 Dec 31, 2018 Go to the documentation of atonline_api 0.0.3 Download atonline_api 0.0.3 archive
0.0.2 Dec 31, 2018 Go to the documentation of atonline_api 0.0.2 Download atonline_api 0.0.2 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
36
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
80
Overall:
Weighted score of the above. [more]
64
Learn more about scoring.

We analyzed this package on Jan 15, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.1.0
  • pana: 0.12.10
  • Flutter: 1.1.7

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health suggestions

Fix lib/src/links.dart. (-1 points)

Analysis of lib/src/links.dart reported 2 hints:

line 18 col 10: The class 'Future' was not exported from 'dart:core' until version 2.1, but this code is required to be able to run on earlier versions.

line 82 col 3: The class 'Future' was not exported from 'dart:core' until version 2.1, but this code is required to be able to run on earlier versions.

Maintenance suggestions

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use atonline_api.dart.

Package is pre-v0.1 release. (-10 points)

While there is nothing inherently wrong with versions of 0.0.*, it usually means that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
flutter_localizations 0.0.0
flutter_secure_storage ^3.1.2 3.1.2
http ^0.12.0 0.12.0+1
intl ^0.15.7 0.15.7
mime ^0.9.6+2 0.9.6+2
uni_links ^0.1.4 0.1.4
url_launcher ^4.0.3 4.0.3
Transitive dependencies
async 2.0.8
charcode 1.1.2
collection 1.14.11
http_parser 3.1.3
meta 1.1.6 1.1.7
path 1.6.2
sky_engine 0.0.99
source_span 1.5.1
string_scanner 1.0.4
term_glyph 1.1.0
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test