atonline_flutter 0.0.3

  • README.md
  • Installing
  • Versions
  • new55

atonline_flutter

Package is now known as atonline_api, please update your dependencies.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  atonline_flutter: ^0.0.3

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

Version Uploaded Documentation Archive
0.0.3 Dec 31, 2018 Go to the documentation of atonline_flutter 0.0.3 Download atonline_flutter 0.0.3 archive
0.0.2 Dec 29, 2018 Go to the documentation of atonline_flutter 0.0.2 Download atonline_flutter 0.0.2 archive
0.0.1 Dec 28, 2018 Go to the documentation of atonline_flutter 0.0.1 Download atonline_flutter 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
26
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
60
Overall:
Weighted score of the above. [more]
55
Learn more about scoring.

We analyzed this package on Jan 15, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.1.0
  • pana: 0.12.10
  • Flutter: 1.1.7

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Maintenance issues and suggestions

Maintain CHANGELOG.md. (-20 points)

Changelog entries help clients to follow the progress in your code.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use atonline_flutter.dart.

Package is pre-v0.1 release. (-10 points)

While there is nothing inherently wrong with versions of 0.0.*, it usually means that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
flutter_localizations 0.0.0
flutter_secure_storage ^3.1.2 3.1.2
http ^0.12.0 0.12.0+1
intl ^0.15.7 0.15.7
mime ^0.9.6+2 0.9.6+2
uni_links ^0.1.4 0.1.4
url_launcher ^4.0.3 4.0.3
Transitive dependencies
async 2.0.8
charcode 1.1.2
collection 1.14.11
http_parser 3.1.3
meta 1.1.6 1.1.7
path 1.6.2
sky_engine 0.0.99
source_span 1.5.1
string_scanner 1.0.4
term_glyph 1.1.0
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test