audiofile_plugin 0.0.4

  • Example
  • Installing
  • Versions
  • new54


A new Flutter plugin.

Getting Started

For help getting started with Flutter, view our online documentation.

For help on editing plugin code, view the documentation.

[0.0.1] - TODO: Add release date.

  • TODO: Describe initial release.


import 'package:flutter/material.dart';
import 'package:flutter/services.dart';
import 'package:audiofile_plugin/audiofile_plugin.dart';

void main() => runApp(new MyApp());

class MyApp extends StatefulWidget {
  _MyAppState createState() => new _MyAppState();

class _MyAppState extends State<MyApp> {
  String _platformVersion = 'Unknown';

  initState() {

  // Platform messages are asynchronous, so we initialize in an async method.
  initPlatformState() async {
    String platformVersion;
    // Platform messages may fail, so we use a try/catch PlatformException.
    try {
      platformVersion = await AudiofilePlugin.platformVersion;
    } on PlatformException {
      platformVersion = 'Failed to get platform version.';

    // If the widget was removed from the tree while the asynchronous platform
    // message was in flight, we want to discard the reply rather than calling
    // setState to update our non-existent appearance.
    if (!mounted)

    setState(() {
      _platformVersion = platformVersion;

  Widget build(BuildContext context) {
    return new MaterialApp(
      home: new Scaffold(
        appBar: new AppBar(
          title: new Text('Plugin example app'),
        body: new Center(
          child: new Text('Running on: $_platformVersion\n'),

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  audiofile_plugin: ^0.0.4

2. Install it

You can install packages from the command line:

with Flutter:

$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:audiofile_plugin/audiofile_plugin.dart';
Version Uploaded Documentation Archive
0.0.4 Aug 25, 2018 Go to the documentation of audiofile_plugin 0.0.4 Download audiofile_plugin 0.0.4 archive
0.0.3 Aug 25, 2018 Go to the documentation of audiofile_plugin 0.0.3 Download audiofile_plugin 0.0.3 archive
0.0.2 Aug 25, 2018 Go to the documentation of audiofile_plugin 0.0.2 Download audiofile_plugin 0.0.2 archive
0.0.1 Aug 24, 2018 Go to the documentation of audiofile_plugin 0.0.1 Download audiofile_plugin 0.0.1 archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Sep 18, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0
  • pana: 0.12.3
  • Flutter: 0.8.4


Detected platforms: Flutter

References Flutter, and has no conflicting libraries.


The description is too short.

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Package is pre-v0.1 release.

While there is nothing inherently wrong with versions of 0.0.*, it usually means that the author is still experimenting with the general direction of the API.

Fix lib/album_music.dart.

Analysis of lib/album_music.dart reported 1 hint:

line 81 col 15: The value of the local variable 'duration' isn't used.

Fix lib/artist_music.dart.

Analysis of lib/artist_music.dart reported 1 hint:

line 77 col 15: The value of the local variable 'duration' isn't used.

Format lib/audio.dart.

Run flutter format to format lib/audio.dart.

Fix additional 6 files with analysis or formatting issues.

Additional issues in the following files:

  • lib/audio_visualizer.dart (2 hints)
  • lib/audiofile_plugin.dart (5 hints)
  • lib/equalizer.dart (1 hint)
  • lib/playlist_music.dart (Run flutter format to format lib/playlist_music.dart.)
  • lib/storemedia.dart (39 hints)
  • lib/visualizer.dart (Run flutter format to format lib/visualizer.dart.)


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.28.0 <3.0.0
flutter 0.0.0
shared_preferences ^0.4.2 0.4.2
Transitive dependencies
collection 1.14.11
meta 1.1.6
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8