avalanche_events 0.10.7

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 0

Avalanche events #

  • Stream for decouple many objects
  • Simple subscription on object events
  • Work both, on client and server

All you need is stream

Build Status pub package

c9 - editor


library example_library;

import 'dart:async';

import 'package:avalanche_events/avalanche_events.dart';

/// Extend class
class BestClass extends AvalancheEvents {}
/// Or extend Object with mixins
class OtherBestClass extends Object with NotifyMixin, ObservableMixin {}

void main() {
    BestClass bestClass = new BestClass();
    OtherBestClass otherBestClass = new OtherBestClass();
    
    bestClass.observable(otherBestClass);
    
    /// Just listen self stream
    otherBestClass.on('Event from bestClass', (bool eventData){
        print(eventData); // is true
    });
    
    bestClass.dispatchEvent('Event from bestClass', true);
}

Details #

GRASP - wiki

Observer Design Pattern - sourcemaking

Mediator Design Pattern - sourcemaking

AvalancheEvents Change Log #

0.10.6 #

  • Added SubscriptionMixin

0.10.5 #

  • Update readme
  • Added changelog

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  avalanche_events: ^0.10.7

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:avalanche_events/avalanche_events.dart';
  
Version Uploaded Documentation Archive
0.10.7 Aug 29, 2016 Go to the documentation of avalanche_events 0.10.7 Download avalanche_events 0.10.7 archive
0.10.6 Aug 17, 2016 Go to the documentation of avalanche_events 0.10.6 Download avalanche_events 0.10.6 archive
0.10.5 Aug 15, 2016 Go to the documentation of avalanche_events 0.10.5 Download avalanche_events 0.10.5 archive
0.10.4 Aug 15, 2016 Go to the documentation of avalanche_events 0.10.4 Download avalanche_events 0.10.4 archive
0.10.3 Aug 15, 2016 Go to the documentation of avalanche_events 0.10.3 Download avalanche_events 0.10.3 archive
0.10.2 Aug 15, 2016 Go to the documentation of avalanche_events 0.10.2 Download avalanche_events 0.10.2 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.