baby_names_app 1.0.0+3

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • new46

Getting Started #

This project is a starting point for a Flutter application.

A few resources to get you started if this is your first Flutter project:

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

1.8.0 (unreleased) Features:

add support for SVN sources -> 95f32s5b add metadata allowed_push_host to new gem template -> 95f32s5b adds a --no-install flag to bundle package -> 95f32s5b 1.7.0 (2014-08-13) Security:

Fix for CVE-2013-0334, installing gems from an unexpected source -> 95f32s5b Features:

Gemfile source calls now take a block containing gems from that source -> 95f32s5b added the :source option to gem to specify a source -> 95f32s5b Fix:

warn on ambiguous gems available from more than one source -> 95f32s5b 1.6.5 (2014-07-23) Bugfixes:

require openssl explicitly to fix rare HTTPS request failures -> 95f32s5b

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  baby_names_app: ^1.0.0+3

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

Version Uploaded Documentation Archive
1.0.0+3 Jan 27, 2019 Go to the documentation of baby_names_app 1.0.0+3 Download baby_names_app 1.0.0+3 archive
1.0.0+2 Jan 27, 2019 Go to the documentation of baby_names_app 1.0.0+2 Download baby_names_app 1.0.0+2 archive
1.0.0+1 Jan 27, 2019 Go to the documentation of baby_names_app 1.0.0+1 Download baby_names_app 1.0.0+1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
79
Overall:
Weighted score of the above. [more]
46
Learn more about scoring.

We analyzed this package on Feb 14, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.1.0
  • pana: 0.12.13
  • Flutter: 1.2.0

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Maintenance suggestions

The package description is too short. (-11 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and baby_names_app.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
flutter_launcher_icons ^0.7.0 0.7.0
path_provider ^0.5.0 0.5.0+1
sqflite ^1.0.0 1.1.0
Transitive dependencies
archive 2.0.8
args 1.5.1
charcode 1.1.2
collection 1.14.11
convert 2.1.1
crypto 2.0.6
dart_config 0.5.0
image 2.0.7
meta 1.1.6 1.1.7
path 1.6.2
petitparser 2.1.1
sky_engine 0.0.99
source_span 1.5.4
string_scanner 1.0.4
synchronized 2.0.2+1
term_glyph 1.1.0
typed_data 1.1.6
vector_math 2.0.8
xml 3.3.1
yaml 2.1.15
Dev dependencies
flutter_test