badge 0.0.3

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 46

badge

A Flutter widget that help you to create badges easily.

badges

Getting Started

Add dependency to pubspec.yaml

[...]
dependencies:
  badge: any
[...]

Install the package using Terminal

$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

import

import 'package:badge/badge.dart';

Example

new Badge.before(
  value: "Text", // value to show inside the badge
  child: new Text("button") // text to append (required)
)

For help getting started with Flutter, view our online documentation.

For help on editing package code, view the documentation.

[0.0.1] - 5th May 2018.

  • initial release.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  badge: ^0.0.3

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:badge/badge.dart';
  
Version Uploaded Documentation Archive
0.0.3 Sep 10, 2018 Go to the documentation of badge 0.0.3 Download badge 0.0.3 archive
0.0.2 May 7, 2018 Go to the documentation of badge 0.0.2 Download badge 0.0.2 archive
0.0.1 May 7, 2018 Go to the documentation of badge 0.0.1 Download badge 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
89
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
10
Overall:
Weighted score of the above. [more]
46
Learn more about scoring.

We analyzed this package on Jan 15, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.1.0
  • pana: 0.12.10
  • Flutter: 1.1.7

Platforms

Detected platforms:

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Analysis issues and suggestions

Fix dependencies in pubspec.yaml.

Running flutter packages pub upgrade failed with the following output:

ERR: The current Dart SDK version is 2.1.1-dev.0.1.flutter-ec86471ccc.
 
 Because badge requires SDK version >=1.20.1 <=2.1.0, version solving failed.

Health suggestions

Format lib/badge.dart.

Run flutter format to format lib/badge.dart.

Maintenance issues and suggestions

Fix platform conflicts. (-20 points)

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Support latest stable Dart SDK in pubspec.yaml. (-20 points)

The SDK constraint in pubspec.yaml doesn't allow the latest stable Dart SDK release.

Running dartdoc failed. (-10 points)

Make sure dartdoc runs without any issues.

The description is too short. (-20 points)

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use badge.dart.

Package is pre-v0.1 release. (-10 points)

While there is nothing inherently wrong with versions of 0.0.*, it usually means that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.20.1 <=2.1.0