banner 0.1.3

  • Installing
  • Versions
  • 79



Getting Started

For help getting started with Flutter, view our online documentation.

For help on editing package code, view the documentation.


  • data 传入list<*>
  • onBannerClickListener(index,itemData) 点击事件
  • delayTime 秒 延迟多少秒进入下一页
  • scrollTime 毫秒 滑动至下页需要秒数
  • height 高度
  • buildShowView(index,itemData) 返回一个用于展示的widget


    new BannerView(
          data: ['a', 'b', 'c'],
          buildShowView: (index,data) {
            return new CustomWidget(text: data);
          onBannerClickListener: (index,data){

[0.0.1] - TODO: Add release date.

  • TODO: Describe initial release.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  banner: ^0.1.3

2. Install it

You can install packages from the command line:

with Flutter:

$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:banner/banner.dart';
Version Uploaded Documentation Archive
0.1.3 Sep 12, 2018 Go to the documentation of banner 0.1.3 Download banner 0.1.3 archive
0.1.2 Sep 12, 2018 Go to the documentation of banner 0.1.2 Download banner 0.1.2 archive
0.1.0 Sep 12, 2018 Go to the documentation of banner 0.1.0 Download banner 0.1.0 archive
0.0.9 Sep 12, 2018 Go to the documentation of banner 0.0.9 Download banner 0.0.9 archive
0.0.8 Sep 12, 2018 Go to the documentation of banner 0.0.8 Download banner 0.0.8 archive
0.0.7 Sep 12, 2018 Go to the documentation of banner 0.0.7 Download banner 0.0.7 archive
0.0.6 Sep 1, 2018 Go to the documentation of banner 0.0.6 Download banner 0.0.6 archive
0.0.5 May 23, 2018 Go to the documentation of banner 0.0.5 Download banner 0.0.5 archive
0.0.4 May 23, 2018 Go to the documentation of banner 0.0.4 Download banner 0.0.4 archive
0.0.3 Mar 17, 2018 Go to the documentation of banner 0.0.3 Download banner 0.0.3 archive

All 12 versions...

Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Dec 5, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.1.0
  • pana: 0.12.7
  • Flutter: 1.0.0


Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health suggestions

Fix lib/banner.dart. (-1 points)

Analysis of lib/banner.dart reported 2 hints:

line 54 col 26: The member 'positions' can only be used within instance members of subclasses of 'package:flutter/src/widgets/scroll_controller.dart'.

line 72 col 12: The value of the local variable 'screenWidth' isn't used.

Maintenance issues and suggestions

The description contains too many non-ASCII characters. (-20 points)

The site uses English as it's primary language. Please use a description that primarily contains characters used when writing English.

The description is too short. (-20 points)

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use banner.dart.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11
meta 1.1.6
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies