banner 0.0.5

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 41

BannerView

flutter的轮播图控件

Getting Started

For help getting started with Flutter, view our online documentation.

For help on editing package code, view the documentation.

###属性

  • data 传入list<*>
  • onBannerClickListener(index,itemData) 点击事件
  • delayTime 秒 延迟多少秒进入下一页
  • scrollTime 毫秒 滑动至下页需要秒数
  • height 高度
  • buildShowView(index,itemData) 返回一个用于展示的widget

###例子

    new BannerView(
          data: ['a', 'b', 'c'],
          buildShowView: (index,data) {
            print(data);
            return new CustomWidget(text: data);
          },
          onBannerClickListener: (index,data){
            print(index);
          },
        ),

[0.0.1] - TODO: Add release date.

  • TODO: Describe initial release.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  banner: ^0.0.5

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:banner/banner.dart';
  
Version Uploaded Documentation Archive
0.0.5 May 23, 2018 Go to the documentation of banner 0.0.5 Download banner 0.0.5 archive
0.0.4 May 23, 2018 Go to the documentation of banner 0.0.4 Download banner 0.0.4 archive
0.0.3 Mar 17, 2018 Go to the documentation of banner 0.0.3 Download banner 0.0.3 archive
0.0.2 Mar 17, 2018 Go to the documentation of banner 0.0.2 Download banner 0.0.2 archive
0.0.1 Mar 17, 2018 Go to the documentation of banner 0.0.1 Download banner 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
82
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
41
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.23.0 <2.0.0