base_href_rewriter 1.0.1

  • README.md
  • Installing
  • Versions
  • 0

Base Href Rewriter

Introduction

This is a transformer that will rewrite the href attribute of your base element to a configurable string when building your application. It is intended to help solve the issue with changing url paths when switching between development and production environments, such as shown here: Angular Tutorial: Routing - base href

Usage

Add the following to your pubspec.yaml.

dev_dependencies:
  base_href_rewriter: any
transformers:
- base_href_rewriter:
    releaseHref: /

This will make pub build and pub serve scan your html-files for the base-element and replace the href with the configured string when building for release. You can also set a default href which will then be used for non-release builds.

transformers:
- base_href_rewriter:
    releaseHref: /
    defaultHref: /mysite/web/

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  base_href_rewriter: ^1.0.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:base_href_rewriter/base_href_rewriter.dart';
  
Version Uploaded Documentation Archive
1.0.1 May 4, 2017 Go to the documentation of base_href_rewriter 1.0.1 Download base_href_rewriter 1.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.23.0 <2.0.0