bazel_ipc 0.0.0

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 0

bazel_ipc

Communicates with the Bazel Build System.

Build Status

This package is currently experimental and requires bazel installed.

0.0.0

  • Initial commit.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  bazel_ipc: ^0.0.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:bazel_ipc/bazel_ipc.dart';
  
Version Uploaded Documentation Archive
0.0.0 Jun 23, 2017 Go to the documentation of bazel_ipc 0.0.0 Download bazel_ipc 0.0.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.22.0 <2.0.0