bear 0.4.1

  • README.md
  • Installing
  • Versions
  • 36

Bear

A simple web framework in Dart

Features

  • GET, POST, PATCH, PUT, DELETE Http methods
  • Variable parameters
  • Middlewares

Usage

final bear = Bear();

bear.get("/", (BearContext c) {
  c.response
    ..write("Bear rocks!")
    ..close();
}
...

bear.listen();

Documentation

https://ogromny.github.io/Bear/bear/bear-library.html

Roadmap

0.4

  • [x] Total rewrite

0.3

  • [x] Static files support

0.2

  • [x] MimeTypes
  • [x] Middlewares

0.1

  • [x] GET, POST, PATCH, PUT, DELETE
  • [x] variable parameters

Contact

In French or in English

ogromnycoding@gmail.com

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  bear: ^0.4.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:bear/bear.dart';
  
Version Uploaded Documentation Archive
0.4.1 Aug 27, 2018 Go to the documentation of bear 0.4.1 Download bear 0.4.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
30
Overall:
Weighted score of the above. [more]
36
Learn more about scoring.

We analyzed this package on Nov 14, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0
  • pana: 0.12.6

Platforms

Detected platforms: Flutter, other

Primary library: package:bear/bear.dart with components: io.

Health suggestions

Format lib/bear.dart.

Run dartfmt to format lib/bear.dart.

Format lib/src/context/bear_context.dart.

Run dartfmt to format lib/src/context/bear_context.dart.

Format lib/src/middleware/bear_middleware.dart.

Run dartfmt to format lib/src/middleware/bear_middleware.dart.

Format lib/src/middleware/bear_middlewares.dart.

Run dartfmt to format lib/src/middleware/bear_middlewares.dart.

Format lib/src/router/bear_route.dart.

Run dartfmt to format lib/src/router/bear_route.dart.

Maintenance issues and suggestions

Maintain CHANGELOG.md. (-20 points)

Changelog entries help clients to follow the progress in your code.

Use constrained dependencies. (-20 points)

The pubspec.yaml contains 2 dependencies without version constraints. Specify version ranges for the following dependencies: mime, path.

The description is too short. (-20 points)

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use bear.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 <3.0.0
mime any 0.9.6+2
path any 1.6.2
Dev dependencies
http any
test any