belt 0.1.0

  • README.md
  • Installing
  • Versions
  • 28

Utility Belt

Belt is a Utility Belt library designed for command-line applications and servers.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  belt: ^0.1.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:belt/io.dart';
import 'package:belt/qts.dart';
  
Version Uploaded Documentation Archive
0.1.0 May 14, 2016 Go to the documentation of belt 0.1.0 Download belt 0.1.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
95
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
28
Learn more about scoring.

We analyzed this package on Jul 20, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0-dev.69.0
  • pana: 0.11.7

Platforms

Detected platforms: Flutter, other

Platform components identified in package: io.

Issues and suggestions

Maintain CHANGELOG.md.

Changelog entries help clients to follow the progress in your code.

Package is too old.

The package was released more than two years ago.

The description is too short.

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Package is pre-v1 release.

While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction of the API.

Fix lib/src/qts/server.dart.

Analysis of lib/src/qts/server.dart reported 4 hints:

line 34 col 37: 'NOT_FOUND' is deprecated and shouldn't be used.

line 58 col 39: 'SIGINT' is deprecated and shouldn't be used.

line 60 col 22: 'UTF8' is deprecated and shouldn't be used.

line 63 col 20: 'JSON' is deprecated and shouldn't be used.

Fix lib/src/io/system.dart.

Analysis of lib/src/io/system.dart reported 3 hints:

line 17 col 30: 'ANY_IP_V6' is deprecated and shouldn't be used.

line 19 col 30: 'ANY_IP_V4' is deprecated and shouldn't be used.

line 28 col 42: 'IP_V6' is deprecated and shouldn't be used.

Fix lib/src/qts/client.dart.

Analysis of lib/src/qts/client.dart reported 3 hints:

line 43 col 19: 'SIGINT' is deprecated and shouldn't be used.

line 60 col 13: 'UTF8' is deprecated and shouldn't be used.

line 60 col 25: 'JSON' is deprecated and shouldn't be used.

Fix lib/src/io/process.dart.

Analysis of lib/src/io/process.dart reported 1 hint:

line 201 col 53: 'APPEND' is deprecated and shouldn't be used.

Maintain an example.

None of the files in your example/ directory matches a known example patterns. Common file name patterns include: main.dart, example.dart or you could also use belt.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.11.0
path ^1.3.9 1.6.2