belt 0.1.0

  • Installing
  • Versions
  • 9

Utility Belt

Belt is a Utility Belt library designed for command-line applications and servers.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  belt: ^0.1.0

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:belt/io.dart';
import 'package:belt/qts.dart';
Version Uploaded Documentation Archive
0.1.0 May 14, 2016 Go to the documentation of belt 0.1.0 Download belt 0.1.0 archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Jan 15, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.1.0
  • pana: 0.12.10


Detected platforms:

Low code quality prevents platform classification.

Health issues and suggestions

Fix lib/src/qts/server.dart. (-44.31 points)

Analysis of lib/src/qts/server.dart failed with 2 errors, 2 hints:

line 60 col 22: Undefined name 'UTF8'.

line 63 col 20: Undefined name 'JSON'.

line 34 col 37: 'NOT_FOUND' is deprecated and shouldn't be used.

line 58 col 39: 'SIGINT' is deprecated and shouldn't be used.

Fix lib/src/qts/client.dart. (-44.03 points)

Analysis of lib/src/qts/client.dart failed with 2 errors, 1 hint:

line 60 col 13: Undefined name 'UTF8'.

line 60 col 25: Undefined name 'JSON'.

line 43 col 19: 'SIGINT' is deprecated and shouldn't be used.

Fix lib/src/io/system.dart. (-1.49 points)

Analysis of lib/src/io/system.dart reported 3 hints:

line 17 col 30: 'ANY_IP_V6' is deprecated and shouldn't be used.

line 19 col 30: 'ANY_IP_V4' is deprecated and shouldn't be used.

line 28 col 42: 'IP_V6' is deprecated and shouldn't be used.

Fix additional 3 files with analysis or formatting issues. (-1 points)

Additional issues in the following files:

  • lib/qts.dart (1 hint)
  • lib/src/io/process.dart (1 hint)
  • lib/src/io/path.dart (Run dartfmt to format lib/src/io/path.dart.)

Maintenance issues and suggestions

Fix platform conflicts. (-20 points)

Low code quality prevents platform classification.

Package is too old. (-100 points)

The package was released more than two years ago.

Maintain (-20 points)

Changelog entries help clients to follow the progress in your code.

The description is too short. (-20 points)

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Maintain an example.

None of the files in your example/ directory matches a known example patterns. Common file name patterns include: main.dart, example.dart or you could also use belt.dart. Packages with multiple examples should use example/


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.11.0
path ^1.3.9 1.6.2