benchpress 2.0.0-beta.17

  • README.md
  • Installing
  • Versions
  • 0

Benchpress - a framework for e2e performance tests

The sources for this package are in the main Angular2 repo. Please file issues and pull requests against that repo.

License: Apache MIT 2.0

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  benchpress: ^2.0.0-beta.17

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:benchpress/benchpress.dart';
  
Version Uploaded Documentation Archive
2.0.0-beta.17 Apr 28, 2016 Go to the documentation of benchpress 2.0.0-beta.17 Download benchpress 2.0.0-beta.17 archive
2.0.0-beta.16 Apr 26, 2016 Go to the documentation of benchpress 2.0.0-beta.16 Download benchpress 2.0.0-beta.16 archive
2.0.0-beta.15 Apr 13, 2016 Go to the documentation of benchpress 2.0.0-beta.15 Download benchpress 2.0.0-beta.15 archive
2.0.0-beta.14 Apr 7, 2016 Go to the documentation of benchpress 2.0.0-beta.14 Download benchpress 2.0.0-beta.14 archive
2.0.0-beta.13 Mar 31, 2016 Go to the documentation of benchpress 2.0.0-beta.13 Download benchpress 2.0.0-beta.13 archive
2.0.0-beta.12 Mar 24, 2016 Go to the documentation of benchpress 2.0.0-beta.12 Download benchpress 2.0.0-beta.12 archive
2.0.0-beta.11 Mar 18, 2016 Go to the documentation of benchpress 2.0.0-beta.11 Download benchpress 2.0.0-beta.11 archive
2.0.0-beta.10 Mar 17, 2016 Go to the documentation of benchpress 2.0.0-beta.10 Download benchpress 2.0.0-beta.10 archive
2.0.0-beta.9 Mar 9, 2016 Go to the documentation of benchpress 2.0.0-beta.9 Download benchpress 2.0.0-beta.9 archive
2.0.0-beta.8 Mar 2, 2016 Go to the documentation of benchpress 2.0.0-beta.8 Download benchpress 2.0.0-beta.8 archive

All 61 versions...

Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.10.0 <2.0.0