big5 0.0.3

  • Installing
  • Versions
  • new50


This package provides encode, decode method for big5.


To use this plugin, add big5 to your package's pubspec.yaml file

big5.decode([119, 111, 114, 100]);

stream version and encode method is ongoing.

[0.0.1] - 2018/05/26

  • add decode method

[0.0.2] - 2018/05/26

  • remote some comments that make flutter fmt failed.

[0.0.3] - 2018/05/26

  • add encode method

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  big5: "^0.0.3"

2. Install it

You can install packages from the command line:

with Flutter:

$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

      import 'package:big5/big5.dart';
Version Uploaded Documentation Archive
0.0.3 May 26, 2018 Go to the documentation of big5 0.0.3 Download big5 0.0.3 archive
0.0.2 May 25, 2018 Go to the documentation of big5 0.0.2 Download big5 0.0.2 archive
0.0.1 May 25, 2018 Go to the documentation of big5 0.0.1 Download big5 0.0.1 archive


We analyzed this package on Jun 19, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0-dev.63.0
  • pana: 0.11.3
  • Flutter: 0.5.4


Describes how popular the package is relative to other packages. [more]
0 / 100
Code health derived from static analysis. [more]
100 / 100
Reflects how tidy and up-to-date the package is. [more]
100 / 100
Overall score:
Weighted score of the above. [more]
Learn more about scoring.


Detected platforms: Flutter

References Flutter, and has no conflicting libraries.


  • Package is pre-v1 release.

    While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction API.

  • Maintain an example.

    Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use big5.dart.

  • Fix analysis and formatting issues.

    Analysis or formatting checks reported 2 hints.

    Strong-mode analysis of lib/big5.dart gave the following hint:

    line: 28 col: 7
    The value of the local variable 's' isn't used.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.23.0 <2.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.6 1.14.10
meta 1.1.5
sky_engine 0.0.99
typed_data 1.1.5
vector_math 2.0.6 2.0.7
Dev dependencies
test >=0.12.30 <2.0.0