big5 0.0.3

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 0

big5-dart

This package provides encode, decode method for big5.

Usage

To use this plugin, add big5 to your package's pubspec.yaml file

big5.encode('word');
big5.decode([119, 111, 114, 100]);

stream version and encode method is ongoing.

[0.0.1] - 2018/05/26

  • add decode method

[0.0.2] - 2018/05/26

  • remote some comments that make flutter fmt failed.

[0.0.3] - 2018/05/26

  • add encode method

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  big5: ^0.0.3

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:big5/big5.dart';
  
Version Uploaded Documentation Archive
0.0.3 May 26, 2018 Go to the documentation of big5 0.0.3 Download big5 0.0.3 archive
0.0.2 May 25, 2018 Go to the documentation of big5 0.0.2 Download big5 0.0.2 archive
0.0.1 May 25, 2018 Go to the documentation of big5 0.0.1 Download big5 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.23.0 <2.0.0