biginteger_js 1.0.1

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 0

biginteger_js

Facade for BigInteger.js Javascript library. Provides big number support for Dart.

Documentation

Javascript documentation can be reached here.

How to generate the facade?

In case you want to update to a new version of BigInteger.js or use a different version, do the following steps:

Get the BigInteger.min.js.

Get the BigInteger.d.ts.

dart_js_facade_gen BigInteger.d.ts > biginteger_js.dart

Command to install dart_js_facade_gen,

npm install -g dart_js_facade_gen

Changelog

0.0.1

  • Initial version, created by Stagehand

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  biginteger_js: ^1.0.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:biginteger_js/biginteger_js.dart';
  
Version Uploaded Documentation Archive
1.0.1 Jan 5, 2018 Go to the documentation of biginteger_js 1.0.1 Download biginteger_js 1.0.1 archive
1.0.0 Jan 5, 2018 Go to the documentation of biginteger_js 1.0.0 Download biginteger_js 1.0.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.20.1 <2.0.0