binance_api 0.0.1

  • Example
  • Installing
  • Versions
  • 20


A library for Dart developers.

Created from templates made available by Stagehand under a BSD-style license.


A simple usage example:

import 'package:binance_api/binance_api.dart';

main() {
  var awesome = new Awesome();

Features and bugs

Please file feature requests and bugs at the issue tracker.



  • Prices, Depth, Klines and Ticker


import 'dart:io';
import 'dart:async';
import 'package:http/http.dart';
import 'package:binance_api/binance_api.dart';

main() async {
  BinanceOpen.init(new IOClient());
  /* TODO
    final Map<String, Price> prices = await BinanceOpen.allPrices;
  new Timer.periodic(const Duration(seconds: 10), (_) async {
    final Map<String, Price> prices = await BinanceOpen.allPrices;
    stdout.write('\r' + prices[Mapping.btcUSDT.symbol].price.toString());
  final Depth depth = await BinanceOpen.depth(Mapping.btcUSDT);

1. Depend on it

Add this to your package's pubspec.yaml file:

  binance_api: "^0.0.1"

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter packages get

Alternatively, your editor might support pub get or packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:binance_api/binance_api.dart';
Version Uploaded Documentation Archive
0.0.1 Dec 2, 2017 Go to the documentation of binance_api 0.0.1 Download binance_api 0.0.1 archive


This feature is new.
We welcome feedback.
More details: scoring.

We analyzed this package, and provided a score, details, and suggestions below.

  • tool failures on Feb 10, 2018
  • Dart: 2.0.0-dev.20.0
  • pana: 0.10.1


Describes how popular the package is relative to other packages. [more]
0 / 100
Code health derived from static analysis. [more]
2 / 100
Reflects how tidy and up-to-date the package is. [more]
95 / 100
Overall score:
Weighted score of the above. [more]


Detected platforms: Flutter, web, other

No platform restriction found in primary library package:binance_api/binance_api.dart.


  • Fix lib/src/binance_api_base.dart.

    Strong-mode analysis of lib/src/binance_api_base.dart failed with the following error:

    line: 4 col: 8
    Target of URI doesn't exist: 'package:meta/meta.dart'.

  • Fix issues reported by dartanalyzer.

    dartanalyzer reported 1 error(s) and 0 warning(s).

  • The description is too short.

    Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

  • Package is pre-v1 release.

    While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction API.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.20.1 <2.0.0
http ^0.11.3 0.11.3+16
Transitive dependencies
async 2.0.3 2.0.4
charcode 1.1.1
collection 1.14.5
http_parser 3.1.1
path 1.5.1
source_span 1.4.0
string_scanner 1.0.2
typed_data 1.1.5
Dev dependencies
test ^0.12.0