binance_api 0.0.1

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 0

binance_api

A library for Dart developers.

Created from templates made available by Stagehand under a BSD-style license.

Usage

A simple usage example:

import 'package:binance_api/binance_api.dart';

main() {
  var awesome = new Awesome();
}

Features and bugs

Please file feature requests and bugs at the issue tracker.

Changelog

0.0.1

  • Prices, Depth, Klines and Ticker

example/binance_api_example.dart

import 'dart:io';
import 'dart:async';
import 'package:http/http.dart';
import 'package:binance_api/binance_api.dart';

main() async {
  BinanceOpen.init(new IOClient());
  /* TODO
  {
    final Map<String, Price> prices = await BinanceOpen.allPrices;
    stdout.write(prices[Mapping.btcUSDT.symbol].price.toString());
  }
  new Timer.periodic(const Duration(seconds: 10), (_) async {
    final Map<String, Price> prices = await BinanceOpen.allPrices;
    stdout.write('\r' + prices[Mapping.btcUSDT.symbol].price.toString());
  });
  */
  final Depth depth = await BinanceOpen.depth(Mapping.btcUSDT);
  print(depth.bids);
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  binance_api: ^0.0.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:binance_api/binance_api.dart';
  
Version Uploaded Documentation Archive
0.0.1 Dec 2, 2017 Go to the documentation of binance_api 0.0.1 Download binance_api 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.20.1 <2.0.0