Utilities for working with binary data and bit manipulation in Dart.
NOTE: Unless otherwise noted, all functionality is based around treating bits as little endian, that is in a 32-bit integer the leftmost bit is 31 and the rightmost bit is 0
This library supports an
Integral data type for fluent bit manipulation:
print(uint8.toBinaryPadded(196)); // '11000100'
Because of Dart's ability to do advanced inlining in both the Dart VM and
dart2js, this library should perform well and be extremely easy to use for most
use cases. For example, it's used in an
This library has a combination of top-level methods, and instance methods of
Integral data types (see below). For example there are two ways
to clear (set to
0) a bit:
// Sets the 0th bit in an (int) bits to 0 bits = clearBit(bits, 0)
However, this will not do range validation. Use
// Sets the 0th bit in a uint32 to 0. // In dev-mode, if either bits or `n` is out of range it throws. bits = uint32.clearBit(bits, 0);
See the dartdocs for more about the API.
signExtendas a method to
uint128only had a length of 64.
Add this to your package's pubspec.yaml file:
dependencies: binary: ^0.1.3
You can install packages from the command line:
$ pub get
Alternatively, your editor might support
Check the docs for your editor to learn more.
Now in your Dart code, you can use:
|0.1.3||May 15, 2017|
|0.1.2||Mar 19, 2017|
|0.1.1||Mar 18, 2017|
|0.1.0||Feb 19, 2017|
|0.0.4||Feb 11, 2017|
|0.0.3||Feb 9, 2017|
|0.0.2||Feb 9, 2017|
|0.0.1||Feb 8, 2017|
|0.0.0||Feb 7, 2017|
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.
Support Dart 2 in
The SDK constraint in
pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.
dartdoc successfully runs on your package's source files. (-10 points)
Dependencies were not resolved.
|Dart SDK||>=1.23.0-dev.1.0 <2.0.0|