bit_vector 0.4.1

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 0

bit_vector

Build Status

A pure Dart memory-efficient packed representation for bit arrays.

Examples

import 'package:bit_vector/bit_vector.dart';

main() {
  BitVector v = new BitVector();
  v.set(68);
  print(v[68]); // true
  v.toggle(68);
  print(v[68]); // false
}

Changelog

0.4.1

  • Fix broken example code

0.4.0

  • Add andNot, and, or and xor logical operators
  • Add BitVector.from constructor that creates a new BitVector instance from the given BitVector

0.3.0

  • Breaking change - change get method to [] operator

0.2.0

  • Add isEmpty and isNotEmpty getters
  • Add cardinality getter
  • Override hashCode and ==

0.1.0

  • Initial version

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  bit_vector: ^0.4.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:bit_vector/bit_vector.dart';
  
Version Uploaded Documentation Archive
0.4.1 Oct 15, 2016 Go to the documentation of bit_vector 0.4.1 Download bit_vector 0.4.1 archive
0.4.0 Oct 15, 2016 Go to the documentation of bit_vector 0.4.0 Download bit_vector 0.4.0 archive
0.3.0 Oct 13, 2016 Go to the documentation of bit_vector 0.3.0 Download bit_vector 0.3.0 archive
0.2.0 Oct 11, 2016 Go to the documentation of bit_vector 0.2.0 Download bit_vector 0.2.0 archive
0.1.0 Oct 10, 2016 Go to the documentation of bit_vector 0.1.0 Download bit_vector 0.1.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.8.0 <2.0.0