A simpliest Bitcoind client
import 'package:bitcoind_client/bitcoind_client.dart'; var client = new BitcoindClient('http://bitcoinrpc:password@localhost:8332'); client.call('getbalance', params: ['accountname', 0]).then((balance) => print(balance));
You can do request/response/error logging with log callback in constructor
import 'package:logging/logging.dart'; import 'package:bitcoind_client/bitcoind_client.dart'; var log = new Logger('testlog'); log.onRecord.listen((record) => print(new DateTime.now().toString() + ' ' +record.message)); var client = new BitcoindClient('http://bitcoinrpc:password@localhost:8332', log.info); ... or without dependencies ... var client = new BitcoindClient('http://bitcoinrpc:password@localhost:8332', (String message) => print(message));
Add this to your package's pubspec.yaml file:
dependencies: bitcoind_client: ^0.1.9
You can install packages from the command line:
$ pub get
Alternatively, your editor might support
Check the docs for your editor to learn more.
Now in your Dart code, you can use:
|0.1.9||Nov 21, 2013|
|0.1.8||Nov 21, 2013|
|0.1.7||Nov 21, 2013|
|0.1.6||Nov 21, 2013|
|0.1.5||Nov 21, 2013|
|0.1.4||Nov 21, 2013|
|0.1.3||Nov 13, 2013|
|0.1.2||Nov 1, 2013|
|0.1.1||Oct 31, 2013|
|0.1.0+2||Oct 2, 2013|
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.
Support Dart 2 in
The SDK constraint in
pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.
dartdoc successfully runs on your package's source files. (-10 points)
Dependencies were not resolved.
|Dart SDK||>=0.8.10+6 <2.0.0|