bloc_built 0.0.1

  • README.md
  • Installing
  • Versions
  • new36

bloc_helper #

A new Flutter project.

Getting Started #

This project is a starting point for a Flutter application.

A few resources to get you started if this is your first Flutter project:

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  bloc_built: ^0.0.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:bloc_built/bloc_build.dart';
import 'package:bloc_built/builder.dart';
  
Version Uploaded Documentation Archive
0.0.1 Mar 10, 2019 Go to the documentation of bloc_built 0.0.1 Download bloc_built 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
95
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
40
Overall:
Weighted score of the above. [more]
36
Learn more about scoring.

We analyzed this package on Mar 10, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.2.0
  • pana: 0.12.14

Platforms

Detected platforms: other

Platform components identified in package: build, io, mirrors.

Health suggestions

Fix lib/src/generators/bloc_built_generator.dart. (-3.45 points)

Analysis of lib/src/generators/bloc_built_generator.dart reported 7 hints, including:

line 1 col 8: Unused import: 'dart:async'.

line 2 col 8: Unused import: 'dart:convert'.

line 33 col 18: The value of the local variable 'className' isn't used.

line 37 col 33: The value of the local variable 'allServices' isn't used.

line 52 col 24: The value of the local variable 'paramatersAssert' isn't used.

Fix lib/src/helpers.dart. (-1 points)

Analysis of lib/src/helpers.dart reported 2 hints:

line 52 col 12: Don't explicitly initialize variables to null.

line 61 col 28: 'computeNode' is deprecated and shouldn't be used.

Fix lib/src/bloc_generator.dart. (-0.50 points)

Analysis of lib/src/bloc_generator.dart reported 1 hint:

line 4 col 8: Unused import: 'package:dart_style/dart_style.dart'.

Fix additional 8 files with analysis or formatting issues. (-0.50 points)

Additional issues in the following files:

  • lib/src/utils.dart (1 hint)
  • lib/bloc_build.dart (Run dartfmt to format lib/bloc_build.dart.)
  • lib/builder.dart (Run dartfmt to format lib/builder.dart.)
  • lib/src/annotations.dart (Run dartfmt to format lib/src/annotations.dart.)
  • lib/src/generators/bloc.dart (Run dartfmt to format lib/src/generators/bloc.dart.)
  • lib/src/generators/stream.dart (Run dartfmt to format lib/src/generators/stream.dart.)
  • lib/src/generators/updade.dart (Run dartfmt to format lib/src/generators/updade.dart.)
  • lib/src/metadata.dart (Run dartfmt to format lib/src/metadata.dart.)

Maintenance issues and suggestions

Provide a file named CHANGELOG.md. (-20 points)

Changelog entries help developers follow the progress of your package. See the example generated by stagehand.

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and bloc_built.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
analyzer >=0.32.2 <0.35.0 0.34.3 0.35.3
bloc_annotation ^0.0.2 0.0.2
build >=0.12.6 <2.0.0 1.1.0 1.1.1
build_config >=0.2.6 <0.4.0 0.3.1+4
code_builder ^3.1.3 3.2.0
dart_style ^1.2.2 1.2.3
meta ^1.1.6 1.1.7
path ^1.3.2 1.6.2
rxdart ^0.20.0 0.20.0 0.21.0
source_gen ^0.9.0 0.9.4+1
Transitive dependencies
args 1.5.1
async 2.0.8
built_collection 4.1.0
built_value 6.3.2
charcode 1.1.2
collection 1.14.11
convert 2.1.1
crypto 2.0.6
csslib 0.14.6
fixnum 0.10.9
front_end 0.1.9+1 0.1.13
glob 1.1.7
html 0.13.4+1
json_annotation 2.0.0
kernel 0.3.9+1 0.3.13
logging 0.11.3+2
matcher 0.12.4
package_config 1.0.5
plugin 0.2.0+3
pub_semver 1.4.2
pubspec_parse 0.1.4
quiver 2.0.1
source_span 1.5.5
stack_trace 1.9.3
string_scanner 1.0.4
term_glyph 1.1.0
typed_data 1.1.6
utf 0.9.0+5
watcher 0.9.7+10
yaml 2.1.15
Dev dependencies
test 1.5.1+1