bokain_models 0.3.5

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 0

bokain_models

A library for Dart developers. It is awesome.

Usage

A simple usage example:

import 'package:bokain_models/bokain_models.dart';

main() {
  var awesome = new Awesome();
}

Features and bugs

Please file feature requests and bugs at the issue tracker.

Changelog

0.0.1

  • Initial version, created by Stagehand

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  bokain_models: ^0.3.5

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:bokain_models/bokain_models.dart';
  
Version Uploaded Documentation Archive
0.3.5 Apr 6, 2018 Go to the documentation of bokain_models 0.3.5 Download bokain_models 0.3.5 archive
0.3.4 Apr 6, 2018 Go to the documentation of bokain_models 0.3.4 Download bokain_models 0.3.4 archive
0.2.163 Jun 9, 2017 Go to the documentation of bokain_models 0.2.163 Download bokain_models 0.2.163 archive
0.2.162 Jun 8, 2017 Go to the documentation of bokain_models 0.2.162 Download bokain_models 0.2.162 archive
0.2.161 Jun 8, 2017 Go to the documentation of bokain_models 0.2.161 Download bokain_models 0.2.161 archive
0.2.160 Jun 7, 2017 Go to the documentation of bokain_models 0.2.160 Download bokain_models 0.2.160 archive
0.2.159 Jun 7, 2017 Go to the documentation of bokain_models 0.2.159 Download bokain_models 0.2.159 archive
0.2.158 Jun 7, 2017 Go to the documentation of bokain_models 0.2.158 Download bokain_models 0.2.158 archive
0.2.157 Jun 7, 2017 Go to the documentation of bokain_models 0.2.157 Download bokain_models 0.2.157 archive
0.2.156 Jun 7, 2017 Go to the documentation of bokain_models 0.2.156 Download bokain_models 0.2.156 archive

All 284 versions...

Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Maintenance issues and suggestions

Running dartdoc failed. (-10 points)

Make sure dartdoc runs without any issues.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.44.0 <2.0.0