bootstrap 4.0.0

  • Installing
  • Versions
  • 27

Bootstrap for Pub

Build Status

Just a pub package of Bootstrap, "The most popular front-end framework for developing responsive, mobile first projects on the web."

Currently contains Bootstrap 4.0.0


See the install instructions.


You can include the bootstrap stylesheets and script once you have added this package as a dependency to your application:

    <!-- include the stylesheets -->
    <link rel="stylesheet" href="packages/bootstrap/css/bootstrap.min.css">
    <!-- include the javascript -->
    <script src="" integrity="sha384-KJ3o2DKtIkvYIK3UENzmM7KCkRr/rE9/Qpg6aAZGJwFDMVNA/GpGFF93hXpG5KkN" crossorigin="anonymous"></script>
    <script src="" integrity="sha384-ApNbgh9B+Y1QKtv3Rn7W3mgPxhU9K/ScQsAP7hUibX39j7fakFPskvXusvfa0b4Q" crossorigin="anonymous"></script>

Note that the versions in the snippets above are the non-minified version. The transformer available in this package will automatically rewrite the URI to point to the minified versions when pub is invoked in release mode.

To activate the transformer, update your pubspec.yaml

- bootstrap:
    url: //{{version}}
    version: 4.0.0

The transformer takes up to two optional parameters:

  • url: when specified the local base url (packages/bootstrap/) will be replaced by the given url. This is useful to automatically switch to using a CDN for your production environment.
  • version: when specified, the sub-string "{{version}}" in the url parameter will be replaced with its value.

Learn more

Visit the official Bootstrap homepage for docs and more.




  • Update package to bootstrap 4.0.0


  • Update package to bootstrap 4.0.0-beta.3


  • Update package to bootstrap 4.0.0-alpha.6


  • Update package to bootstrap 3.3.7 and jquery 3.1.1


  • Update package to bootstrap 3.3.6 and jquery 2.2.4


  • Change name from bootstrap_for_pub to bootstrap


  • Bump versions of dependencies

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  bootstrap: ^4.0.0

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:bootstrap/bootstrap.dart';
Version Uploaded Documentation Archive
4.0.0 Feb 3, 2018 Go to the documentation of bootstrap 4.0.0 Download bootstrap 4.0.0 archive
3.3.7 Sep 25, 2016 Go to the documentation of bootstrap 3.3.7 Download bootstrap 3.3.7 archive
3.3.6 Jul 15, 2016 Go to the documentation of bootstrap 3.3.6 Download bootstrap 3.3.6 archive
3.3.4 Apr 18, 2015 Go to the documentation of bootstrap 3.3.4 Download bootstrap 3.3.4 archive
3.3.0+4 Nov 24, 2014 Go to the documentation of bootstrap 3.3.0+4 Download bootstrap 3.3.0+4 archive
3.3.0+3 Nov 24, 2014 Go to the documentation of bootstrap 3.3.0+3 Download bootstrap 3.3.0+3 archive
3.3.0+2 Nov 24, 2014 Go to the documentation of bootstrap 3.3.0+2 Download bootstrap 3.3.0+2 archive
4.0.0-alpha.6 Apr 19, 2017 Go to the documentation of bootstrap 4.0.0-alpha.6 Download bootstrap 4.0.0-alpha.6 archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Fix dependencies in pubspec.yaml.

Running pub upgrade failed with the following output:

ERR: The current Dart SDK version is 2.1.0.
 Because bootstrap depends on barback >=0.6.2 which requires SDK version >=0.6.2 <2.0.0 or >=2.0.0-dev.17.0 <2.0.0, version solving failed.

Health suggestions

Format lib/bootstrap.dart.

Run dartfmt to format lib/bootstrap.dart.

Maintenance issues and suggestions

Add SDK constraint in pubspec.yaml. (-50 points)

For information about setting SDK constraint, please see

Fix platform conflicts. (-20 points)

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Running dartdoc failed. (-10 points)

Make sure dartdoc runs without any issues.

Maintain an example.

None of the files in your example/ directory matches a known example patterns. Common file name patterns include: main.dart, example.dart or you could also use bootstrap.dart. Packages with multiple examples should use example/