bot_io 0.26.4+1

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 51

DEPRECATED. Not maintained.

A collection of Dart file system helpers built on dart:io.

Projects using bot_io

Authors

0.26.4+1

  • Updated dependencies - mostly to fix users of hop.

  • Marked the package as deprecated.

0.26.4

  • Removed link to GitHub docs.
  • Code formatting.

0.26.3

  • Added copyDirectory

0.26.2 2014-05-06

  • Upgrade min dependency on bot to 0.27.0.
  • Stop using deprecated features from bot.

0.26.1+2 2014-05-06

  • Mark Console.supportsColor with @deprecated.

0.26.1 2014-05-06

  • NEW! Added AnsiColor.isSupported
  • DEPRECATED Console.supportsColor use AnsiColor.isSupported instead.

0.26.0 2014-03-05

  • BREAKING removed deprecated completion.dart library. See the completion package.
  • BREAKING removed deprecated bot_git.dart library. See the git package.
  • BREAKING removed deprecated expandStream from bot_io. Now in bot package.
  • Lots of other cleanup.

0.25.3 2014-02-15 (SDK 1.2.0-dev.5.7 32688)

0.25.2 2014-02-15 (SDK 1.2.0-dev.5.7 32688)

  • bot_git is DEPRECATED. Use the git package instead.

0.25.1 2013-12-10 (SDK 1.0.2.1 r30821)

  • DEPRECATED expandStream. You likely weren't using it anyway. If you were, it's in bot now.
  • A bunch of test clean-up.
  • Dependency tweaks.

0.25.0 2013-11-07 (SDK 0.8.10+6 r30036)

0.24.0 2013-10-31 (SDK 0.8.9 r29656)

  • Updates for latest SDK
  • BREAKING changes to tryCompletion and the completion generator due to removal of Options from dart:io.

0.23.3 2013-10-24 (SDK 0.8.6 r29156)

  • Updates for latest SDK

0.23.2 2013-08-26 (SDK 0.6.21.2 r26619)

  • Updates for latest SDK

0.23.1 2013-07-26 (SDK 0.6.9.2 r25388)

  • NEW! TempDir.then - for those times when you just want a directory.
  • Tiny updates to dependencies, refactoring in bot_git

0.23.0 2013-07-24 (SDK 0.6.9.2 r25388)

  • Latest SDK
  • BREAKING Moved completion into its own library.

0.22.0 2013-07-18 (0.6.5.0 r25017)

  • Updated min SDK to 0.6.5
  • Moved from 'pathos' to 'path' package
  • DEPRECATED DirectoryPopulater and MapDirectoryPopulater
  • BREAKING TempDir.populate now takes the same inputs as EntityPopulater.populate

0.21.3 2013-07-11 (SDK 0.6.3.3 r24898)

  • Work-around for https://code.google.com/p/dart/issues/detail?id=10163
  • Other tiny tweaks

0.21.2 2013-06-04 (SDK 0.5.13.1 r23552)

  • Fixes for SDK 0.5.13.1
  • Crypto moved to a pub package

0.21.1 2013-05-28 (SDK 0.5.11.1 r23200)

  • Fixes for SDK 0.5.11.1

0.21.0+2 2013-04-29 (SDK 0.5.1.0 r22072)

bot_io

  • Another oops in AnsiColor
  • Un-deprecated DirectoryPopulater and MapDirecotryPopulater
    • EntityPopulator isn't there yet...

0.21.0+1 2013-04-29 (SDK 0.5.1.0 r22072)

bot_io

  • Oops in AnsiColor

0.21.0 2013-04-29 (SDK 0.5.1.0 r22072)

bot_io

  • BREAKING TempDir.dispose is now async -- returns a Future
  • DEPRECATED DirectoryPopulater and MapDirecotryPopulater
  • NEW! EntityPopulater

0.20.2 2013-04-20 (SDK 0.4.7+5 r21658)

bot_io

  • NEW! fileContentsMatch
  • NEW! fileSha1Hex

0.20.1 2013-04-19 (SDK 0.4.7+5 r21658)

  • TODO...

0.20.0 2013-04-17 (SDK 0.4.7+3 r21604)

  • The grand split from BOT begins.
  • See the BOT Changelog for work leading up to the split.

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  bot_io: "^0.26.4+1"

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:bot_io/bot_io.dart';
        
Version Uploaded Documentation Archive
0.26.4+1 Dec 12, 2017 Go to the documentation of bot_io 0.26.4+1 Download bot_io 0.26.4+1 archive
0.26.4 Mar 21, 2016 Go to the documentation of bot_io 0.26.4 Download bot_io 0.26.4 archive
0.26.3+2 Dec 29, 2014 Go to the documentation of bot_io 0.26.3+2 Download bot_io 0.26.3+2 archive
0.26.3+1 May 25, 2014 Go to the documentation of bot_io 0.26.3+1 Download bot_io 0.26.3+1 archive
0.26.3 May 25, 2014 Go to the documentation of bot_io 0.26.3 Download bot_io 0.26.3 archive
0.26.2 May 7, 2014 Go to the documentation of bot_io 0.26.2 Download bot_io 0.26.2 archive
0.26.1+2 May 6, 2014 Go to the documentation of bot_io 0.26.1+2 Download bot_io 0.26.1+2 archive
0.26.1+1 May 6, 2014 Go to the documentation of bot_io 0.26.1+1 Download bot_io 0.26.1+1 archive
0.26.1 May 6, 2014 Go to the documentation of bot_io 0.26.1 Download bot_io 0.26.1 archive
0.26.0 Mar 5, 2014 Go to the documentation of bot_io 0.26.0 Download bot_io 0.26.0 archive

All 35 versions...

Analysis

We analyzed this package on Apr 23, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0-dev.49.0
  • pana: 0.10.6

Scores

Popularity:
Describes how popular the package is relative to other packages. [more]
5 / 100
Health:
Code health derived from static analysis. [more]
94 / 100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
99 / 100
Overall score:
Weighted score of the above. [more]
51
Learn more about scoring.

Platforms

Detected platforms: Flutter, other

Primary library: package:bot_io/bot_io.dart with components: io.

Suggestions

  • Fix analysis and formatting issues.

    Analysis or formatting checks reported 2 errors 2 hints.

    Strong-mode analysis of lib/src/entity_validator.dart failed with the following error:

    line: 49 col: 37
    The function expression type '(FileSystemEntity) → Stream<dynamic>' isn't of type '(dynamic) → Stream<dynamic>'. This means its parameter or return type does not match what is expected. Consider changing parameter type(s) or the returned type(s).

    Strong-mode analysis of lib/src/temp_dir.dart failed with the following error:

    line: 63 col: 15
    The argument type '(Directory) → TempDir' can't be assigned to the parameter type '(FileSystemEntity) → FutureOr<TempDir>'.

    Similar analysis of the following files failed:

    • lib/src/entity_populater.dart (hint)
  • The description is too short.

    Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

  • Package is pre-v1 release.

    While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction API.

  • Maintain an example.

    Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use bot_io.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.8.0 <2.0.0
bot >=0.27.0 <0.29.0 0.28.0
convert ^2.0.0 2.0.1
crypto ^2.0.0 2.0.2+1
logging >=0.9.0 <0.12.0 0.11.3+1
path >=1.0.0 <2.0.0 1.5.1
Transitive dependencies
charcode 1.1.1
collection 1.14.9
typed_data 1.1.5
Dev dependencies
test ^0.12.0