braxter_client 0.1.1

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 0

braxter (client)

Web UI framework for Dart

Installing braxter

From Pub

dependencies:
  braxter_client: any

Usage

TODO

Changelog

0.1.0

Initial release

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  braxter_client: ^0.1.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:braxter_client/braxter_client.dart';
  
Version Uploaded Documentation Archive
0.1.1 Dec 27, 2016 Go to the documentation of braxter_client 0.1.1 Download braxter_client 0.1.1 archive
0.1.0 Dec 27, 2016 Go to the documentation of braxter_client 0.1.0 Download braxter_client 0.1.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Fix dependencies in pubspec.yaml.

Running pub upgrade failed with the following output:

ERR: The current Dart SDK version is 2.1.0.
 
 Because braxter_client depends on braxter_common any which requires SDK version <2.0.0, version solving failed.

Health suggestions

Format lib/braxter_client.dart.

Run dartfmt to format lib/braxter_client.dart.

Format lib/src/ibraxter_control.dart.

Run dartfmt to format lib/src/ibraxter_control.dart.

Format lib/src/trusted_node_validator.dart.

Run dartfmt to format lib/src/trusted_node_validator.dart.

Maintenance issues and suggestions

Add SDK constraint in pubspec.yaml. (-50 points)

For information about setting SDK constraint, please see https://www.dartlang.org/tools/pub/pubspec#sdk-constraints.

Fix platform conflicts. (-20 points)

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Running dartdoc failed. (-10 points)

Make sure dartdoc runs without any issues.

Package is getting outdated. (-96.99 points)

The package was released 102 weeks ago.

The description is too short. (-20 points)

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use braxter_client.dart.