braze_plugin 0.0.2

  • Example
  • Installing
  • Versions
  • new62

Braze Flutter SDK #

Effective marketing automation is an essential part of successfully scaling and managing your business. Braze empowers you to build better customer relationships through a seamless, multi-channel approach that addresses all aspects of the user life cycle Braze helps you engage your users on an ongoing basis.

This project contains the Braze plug-in package, a specialized package that allows integrators to use certain Braze APIs from Flutter app code written in Dart.

Getting Started #

  1. Add the following to your pubspec.yaml:
braze_plugin: ^0.0.1
  1. Import Braze into your dart source using the following import:
import 'package:braze_plugin/braze_plugin.dart';
  1. Instantiate an instance of the Braze plugin by calling new BrazePlugin()

Android #

  1. In your res/values directory, create a file called appboy.xml and add your API key and set your custom endpoint as specified in our public documentation.

  2. Add required permissions to your AndroidManifest, as specified in our public documentation.

  3. To integrate push, follow the directions in our [public documentation( Note that only registration using our "automatic FCM registration" is currently supported from Flutter apps.

iOS #

  1. Call Appboy.startWithApiKey() in your AppDelegate's didFinishLaunchingWithOptions delegate method as specified in our [public documentation])(

  2. Set your custom endpoint as specified in our public documentation. We recommend the Info.plist approach.

0.0.2 #

  • Updates the version of Kotlin used by the Android plugin from 1.2.71 to 1.3.11.

0.0.1 #


braze_plugin_example #

Demonstrates how to use the braze_plugin plugin.

Getting Started #

This project is a starting point for a Flutter application.

A few resources to get you started if this is your first Flutter project:

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  braze_plugin: ^0.0.2

2. Install it

You can install packages from the command line:

with Flutter:

$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:braze_plugin/braze_plugin.dart';
Version Uploaded Documentation Archive
0.0.2 Feb 21, 2019 Go to the documentation of braze_plugin 0.0.2 Download braze_plugin 0.0.2 archive
0.0.1 Feb 13, 2019 Go to the documentation of braze_plugin 0.0.1 Download braze_plugin 0.0.1 archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Feb 21, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.1.0
  • pana: 0.12.13+1
  • Flutter: 1.2.1


Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health issues and suggestions

Document public APIs. (-1 points)

42 out of 42 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Fix lib/braze_plugin.dart. (-0.50 points)

Analysis of lib/braze_plugin.dart reported 1 hint:

line 1 col 8: Unused import: 'dart:async'.

Maintenance suggestions

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11
meta 1.1.6 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8