browser 0.10.0+3

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 99

This package is no longer maintained.

Supports using Dartium during development for projects using Dart v1.

For projects using Dart v2, this package is no longer needed. See the Dart 2 migration guide for details.

dart.js

The dart.js file is used in Dart browser apps to check for native Dart support and either (a) bootstrap Dartium or (b) load compiled JS instead.

  1. Add the following to your pubspec.yaml:

     dev_dependencies:
       browser: ^0.10.0
    
  2. Run pub install.

  3. Use a relative script tag in your html to the installed version:

     <script src="packages/browser/dart.js"></script>
    

If you do not wish to use pub, you may host a copy of this file locally instead. In this case, you will need to update it yourself as necessary. We reserve the right to move the old file in the repository, so we no longer recommend linking to it directly.

interop.js

This script was required for dart:js interop to work, but it is no longer needed. The functionality is now supported by dart:js directly.

If you previously had a script such as this, please remove it:

<script src="packages/browser/interop.js"></script>

0.10.0+3

  • Deprecating package. No functional update.

0.10.0+2 - Mar 18, 2014

  • Last functional update.

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  browser: "^0.10.0+3"

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

Version Uploaded Documentation Archive
0.10.0+3 Mar 15, 2018 Go to the documentation of browser 0.10.0+3 Download browser 0.10.0+3 archive
0.10.0+2 Mar 18, 2014 Go to the documentation of browser 0.10.0+2 Download browser 0.10.0+2 archive
0.10.0+1 Mar 18, 2014 Go to the documentation of browser 0.10.0+1 Download browser 0.10.0+1 archive
0.10.0 Feb 28, 2014 Go to the documentation of browser 0.10.0 Download browser 0.10.0 archive
0.9.1 Jan 2, 2014 Go to the documentation of browser 0.9.1 Download browser 0.9.1 archive
0.9.0 Nov 6, 2013 Go to the documentation of browser 0.9.0 Download browser 0.9.0 archive
0.8.10+4 Nov 5, 2013 Go to the documentation of browser 0.8.10+4 Download browser 0.8.10+4 archive
0.8.10+3 Nov 4, 2013 Go to the documentation of browser 0.8.10+3 Download browser 0.8.10+3 archive
0.8.10 Nov 1, 2013 Go to the documentation of browser 0.8.10 Download browser 0.8.10 archive
0.8.9 Oct 31, 2013 Go to the documentation of browser 0.8.9 Download browser 0.8.9 archive

All 76 versions...

Analysis

We analyzed this package on Apr 9, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0-dev.46.0
  • pana: 0.10.6

Scores

Popularity:
Describes how popular the package is relative to other packages. [more]
99 / 100
Health:
Code health derived from static analysis. [more]
100 / 100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100 / 100
Overall score:
Weighted score of the above. [more]
99
Learn more about scoring.

Platforms

Detected platforms: web

Whitelisted platform override.

Suggestions

  • Package is pre-v1 release.

    While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction API.

  • Maintain an example.

    Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use browser.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.8.0 <2.0.0