browser_detect 1.0.4

  • README.md
  • Installing
  • Versions
  • 29

Browser Detect #

A package that detects the browser being used to view a web page. Useful for blanket browser detection. If possible, try to use feature detection over this approach.

Usage #

Import the Browser Detect package.

import 'package:browser_detect/browser_detect.dart';

Use the library's browser field to query for information about the detected browser. This field contains properties for checking the browser type and version.

if (browser.isIe && browser.version <= "9") {
  // Do something.
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  browser_detect: ^1.0.4

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:browser_detect/browser_detect.dart';
  
Version Uploaded Documentation Archive
1.0.4 Mar 2, 2016 Go to the documentation of browser_detect 1.0.4 Download browser_detect 1.0.4 archive
1.0.3 Mar 7, 2014 Go to the documentation of browser_detect 1.0.3 Download browser_detect 1.0.3 archive
1.0.2 Feb 26, 2014 Go to the documentation of browser_detect 1.0.2 Download browser_detect 1.0.2 archive
1.0.1 Jan 24, 2014 Go to the documentation of browser_detect 1.0.1 Download browser_detect 1.0.1 archive
0.1.0+2 Sep 20, 2013 Go to the documentation of browser_detect 0.1.0+2 Download browser_detect 0.1.0+2 archive
0.1.0+1 Sep 19, 2013 Go to the documentation of browser_detect 0.1.0+1 Download browser_detect 0.1.0+1 archive
0.1.0 Sep 13, 2013 Go to the documentation of browser_detect 0.1.0 Download browser_detect 0.1.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
57
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
29
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.