bson_codec 0.1.0

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 0

bson_codec

This package offers Dart programs a flexible serializer and deserializer for BSON documents.

Highlights

  • Standard Codec/Encoder/Decoder interface, as established by the standard 'dart:convert' package.
  • Best effort type mapping when serializing/deserializing values.

Examples

import 'package:bson_codec/bson_codec.dart';

main() {
  final doc = {
    '_id': 5,
    'a': [2, 3, 5]
  };
  List<int> bytes = BSON.encode(doc);
  final root = BSON.decode(bytes);
  print(doc['a'][2]); // 5
}

TODO

JavaScript code w/ scope and decimal128 are not supported yet.

Changelog

0.1.0

  • Initial version

example/bson_codec_example.dart

// Copyright (c) 2016, Kwang Yul Seo. All rights reserved. Use of this source code
// is governed by a BSD-style license that can be found in the LICENSE file.

import 'dart:io';

import 'package:bson_codec/bson_codec.dart';

main() {
  List<int> bytes = new File('sample.bson').readAsBytesSync();
  final o = BSON.decode(bytes);
  print(o);
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  bson_codec: ^0.1.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:bson_codec/bson_codec.dart';
  
Version Uploaded Documentation Archive
0.2.0 Oct 12, 2016 Go to the documentation of bson_codec 0.2.0 Download bson_codec 0.2.0 archive
0.1.0 Oct 8, 2016 Go to the documentation of bson_codec 0.1.0 Download bson_codec 0.1.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

This package version is not analyzed, because it is more than two years old. Check the latest stable version for its analysis.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Maintenance issues and suggestions

Running dartdoc failed. (-10 points)

Make sure dartdoc runs without any issues.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.8.0 <2.0.0