bubble_tab_indicator 0.1.2

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • new50

Bubble Tab Indicator

pub package

A Flutter library to add bubble tab indicator to TabBar.

banner

Getting Started

Add package from github by adding the following to your pubspec.yaml, pub publication is added later.

  dependencies:
    bubble_tab_indicator: "^0.1.2"

Import the library in your file:

import 'package:bubble_tab_indicator/bubble_tab_indicator.dart';

Use the BubbleTabIndicator like this:

new TabBar(
  indicatorSize: TabBarIndicatorSize.tab,
  indicator: new BubbleTabIndicator(
    indicatorHeight: 25.0,
    indicatorColor: Colors.blueAccent,
    tabBarIndicatorSize: TabBarIndicatorSize.tab,
  ),
)

0.1.2

  • Updated Readme and screenshot

0.1.1

  • Updated Readme and some code formatting

0.1.0

  • Initial open source release

example/lib/main.dart

import 'package:flutter/widgets.dart';
import 'application.dart';

void main() {
  runApp(new CustomTabApp());
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  bubble_tab_indicator: "^0.1.2"

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


      import 'package:bubble_tab_indicator/bubble_tab_indicator.dart';
  
Version Uploaded Documentation Archive
0.1.2 May 21, 2018 Go to the documentation of bubble_tab_indicator 0.1.2 Download bubble_tab_indicator 0.1.2 archive
0.1.1 May 21, 2018 Go to the documentation of bubble_tab_indicator 0.1.1 Download bubble_tab_indicator 0.1.1 archive
0.1.0 May 21, 2018 Go to the documentation of bubble_tab_indicator 0.1.0 Download bubble_tab_indicator 0.1.0 archive

Analysis

We analyzed this package on Jun 12, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0-dev.60.0
  • pana: 0.11.3
  • Flutter: 0.5.2

Scores

Popularity:
Describes how popular the package is relative to other packages. [more]
0 / 100
Health:
Code health derived from static analysis. [more]
100 / 100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100 / 100
Overall score:
Weighted score of the above. [more]
50
Learn more about scoring.

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Suggestions

  • The description is too short.

    Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

  • Package is pre-v1 release.

    While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.23.0 <2.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.6 1.14.10
meta 1.1.5
sky_engine 0.0.99
typed_data 1.1.5
vector_math 2.0.6 2.0.7
Dev dependencies
flutter_test