build_compilers 0.2.0

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 0

DEPRECATED This package was moved to build_web_compilers.

0.2.0

DEPRECATED This package was moved to build_web_compilers.

0.1.1-dev

  • Mark ddc_bootstrap builder with build_to: cache.

0.1.0

  • Add builder factories.
  • Fixed temp dir cleanup bug on windows.
  • Enabled support for running tests in --precompiled mode.

0.0.1

  • Initial release with support for building analyzer summaries and DDC modules.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  build_compilers: ^0.2.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

Version Uploaded Documentation Archive
0.2.0 Dec 27, 2017 Go to the documentation of build_compilers 0.2.0 Download build_compilers 0.2.0 archive
0.1.0 Nov 30, 2017 Go to the documentation of build_compilers 0.1.0 Download build_compilers 0.1.0 archive
0.0.1 Nov 3, 2017 Go to the documentation of build_compilers 0.0.1 Download build_compilers 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Maintenance issues and suggestions

Running dartdoc failed. (-10 points)

Make sure dartdoc runs without any issues.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.22.1 <2.0.0