build_modules 0.2.2+6

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 21

build_modules

Module builders for web, used by package:build_web_compilers.
Build Status Issues related to build_modules Pub Package Version Latest Dartdocs Join the chat on Gitter

This package provides generic module builders which can be used to create custom web compilation pipelines. It is used by build_web_compilers package which provides standard builders for DDC and dart2js.

Usage

There should be no need to import this package directly unless you are developing a custom builder for web. See documentation in build_web_compilers for more details on building your Dart code with DDC and dart2js.

0.2.2+6

  • Support the latest package:build_config.

0.2.2+5

  • Updated the missing modules message to highlight that the error is likely due to a missing dependency.

0.2.2+4

  • Support package:analyzer 0.32.0.

0.2.2+3

  • Fix a race condition where we could fail to find the modules for some dependencies.

0.2.2+2

  • Fix an issue where modules were unnecessarily being built with DDC. #1375.

0.2.2+1

  • Fix an issue with new files causing subsequent build failures #1358.
  • Expose MetaModuleCleanBuilder and metaModuleCleanExtension publicly for usage in tests and manual build scripts.

0.2.2

  • Clean up .module and summary files from the output and server.

  • Add new ModuleBuilder strategies. By default the coarse strategy is used for all non-root packages and will create a minimum number of modules. This strategy can not be overridden. However, for the root package, the fine strategy will be used which creates a module for each strongly connected component. You can override this behavior by providing coarse to the strategy option.

    Example configuration:

    targets:
      $default:
        builders:
          build_modules|modules:
            options:
              strategy: coarse
    

0.2.1

  • Give a guaranteed reverse dependency order for Module.computeTransitiveDependencies

0.2.0+2

0.2.0+1

0.2.0

  • computeTransitiveDependencies now throws a MissingModulesException instead of logging a warning if it discovers a missing module.

0.1.0+2

  • Fix a bug with the dart2js workers where the worker could hang if you try to re-use it after calling terminateWorkers. This only really surfaces in test environments.

0.1.0+1

  • Fix a bug with imports to libraries that have names starting with dart.

0.1.0

  • Split from build_web_compilers.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  build_modules: ^0.2.2+6

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:build_modules/build_modules.dart';
  
Version Uploaded Documentation Archive
1.0.2 Oct 23, 2018 Go to the documentation of build_modules 1.0.2 Download build_modules 1.0.2 archive
1.0.1 Oct 8, 2018 Go to the documentation of build_modules 1.0.1 Download build_modules 1.0.1 archive
1.0.0 Sep 26, 2018 Go to the documentation of build_modules 1.0.0 Download build_modules 1.0.0 archive
0.4.0 Aug 30, 2018 Go to the documentation of build_modules 0.4.0 Download build_modules 0.4.0 archive
0.3.2 Aug 23, 2018 Go to the documentation of build_modules 0.3.2 Download build_modules 0.3.2 archive
0.3.1+1 Jul 24, 2018 Go to the documentation of build_modules 0.3.1+1 Download build_modules 0.3.1+1 archive
0.3.1 Jul 24, 2018 Go to the documentation of build_modules 0.3.1 Download build_modules 0.3.1 archive
0.3.0 Jul 18, 2018 Go to the documentation of build_modules 0.3.0 Download build_modules 0.3.0 archive
0.2.3 Jun 22, 2018 Go to the documentation of build_modules 0.2.3 Download build_modules 0.2.3 archive
0.2.2+6 Jun 8, 2018 Go to the documentation of build_modules 0.2.2+6 Download build_modules 0.2.2+6 archive

All 23 versions...

Popularity:
Describes how popular the package is relative to other packages. [more]
42
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
21
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.48 <2.0.0