Module builders for web, used by
This package provides generic module builders which can be used to create
custom web compilation pipelines. It is used by
package which provides standard builders for DDC and dart2js.
There should be no need to import this package directly unless you are developing
a custom builder for web. See documentation in
for more details on building your Dart code with DDC and dart2js.
metaModuleCleanExtensionpublicly for usage in tests and manual build scripts.
.module and summary files from the output and server.
ModuleBuilder strategies. By default the
coarse strategy is used
for all non-root packages and will create a minimum number of modules. This
strategy can not be overridden. However, for the root package, the
strategy will be used which creates a module for each strongly
connected component. You can override this behavior by providing
targets: $default: builders: build_modules|modules: options: strategy: coarse
computeTransitiveDependenciesnow throws a
MissingModulesExceptioninstead of logging a warning if it discovers a missing module.
terminateWorkers. This only really surfaces in test environments.
Add this to your package's pubspec.yaml file:
dependencies: build_modules: ^0.2.2+6
You can install packages from the command line:
$ pub get
Alternatively, your editor might support
Check the docs for your editor to learn more.
Now in your Dart code, you can use:
|1.0.2||Oct 23, 2018|
|1.0.1||Oct 8, 2018|
|1.0.0||Sep 26, 2018|
|0.4.0||Aug 30, 2018|
|0.3.2||Aug 23, 2018|
|0.3.1+1||Jul 24, 2018|
|0.3.1||Jul 24, 2018|
|0.3.0||Jul 18, 2018|
|0.2.3||Jun 22, 2018|
|0.2.2+6||Jun 8, 2018|
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.
Support Dart 2 in
The SDK constraint in
pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.
|Dart SDK||>=2.0.0-dev.48 <2.0.0|