firstWhere(orElse)for compatibility with the SDK dev.45
resetcall to indicate that a complete build is finished.
code_transformerswith a near-identical implementation.
Add this to your package's pubspec.yaml file:
dependencies: build_resolvers: "^0.2.0+2"
You can install packages from the command line:
$ pub get
$ flutter packages get
Alternatively, your editor might support
pub get or
flutter packages get.
Check the docs for your editor to learn more.
Now in your Dart code, you can use:
|0.2.0+2||May 15, 2018|
|0.2.0+1||Apr 5, 2018|
|0.2.0||Mar 1, 2018|
|0.1.1||Feb 5, 2018|
|0.1.0||Feb 1, 2018|
We analyzed this package on Jun 12, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Detected platforms: Flutter, other
Readme should inform others about your project, what it does, and how they can use it.
The description is too short.
Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.
Package is pre-v1 release.
While there is nothing inherently wrong with versions of
0.*.*, it usually means that the author is still experimenting with the general direction API.
Maintain an example.
Create a short demo in the
example/directory to show how to use this package. Common file name patterns include:
example.dartor you could also use
|Dart SDK||>=2.0.0-dev.32 <2.0.0|