build_shell 1.0.0

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 50

build_shell #

Pub

Builds shell scripts that execute Dart snapshots (from build_vm_compilers).

Rationale #

This package alleviates an inconvenience - at this point in time, even though you can build .dill files via package:build_vm_compilers, those files are placed in the cache, rather than in your actual project. So, actually running them becomes a little more complex.

This tool just creates shell scripts to let you run them. This way, your script only has to be compiled once, leading to faster startup times.

Installation #

In your pubspec.yaml:

dependencies:
  build_shell: ^1.0.0
dev_dependencies:
  build_runner: ^1.0.0

Usage #

Simply run:

pub run build_runner build.

You'll then see a .sh and .bat file generated for every Dart script with a main method.

1.0.0 #

  • Initial version, created by Stagehand

example/build_shell_example.dart

/// Empty file for the sake of Pub score...
void main() {
  print('Hello...');
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  build_shell: ^1.0.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:build_shell/build_shell.dart';
  
Version Uploaded Documentation Archive
1.0.0 Jan 25, 2019 Go to the documentation of build_shell 1.0.0 Download build_shell 1.0.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
50
Learn more about scoring.

We analyzed this package on Apr 19, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.2.0
  • pana: 0.12.14

Platforms

Detected platforms: Flutter, other

Primary library: package:build_shell/build_shell.dart with components: io, build.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev <3.0.0
build ^1.0.0 1.1.3
build_config ^0.3.0 0.3.2
build_vm_compilers ^0.1.1 0.1.2 1.0.0
path ^1.0.0 1.6.2
scratch_space ^0.0.3 0.0.3+2
Transitive dependencies
analyzer 0.35.4 0.36.0
args 1.5.1
async 2.2.0
bazel_worker 0.1.20
build_modules 1.0.10 2.1.0
charcode 1.1.2
collection 1.14.11
convert 2.1.1
crypto 2.0.6
fixnum 0.10.9
front_end 0.1.14 0.1.15
glob 1.1.7
graphs 0.2.0
json_annotation 2.2.0
kernel 0.3.14 0.3.15
logging 0.11.3+2
meta 1.1.7
package_config 1.0.5
pedantic 1.5.0
pool 1.4.0
protobuf 0.13.11
pub_semver 1.4.2
pubspec_parse 0.1.4
source_span 1.5.5
stack_trace 1.9.3
string_scanner 1.0.4
term_glyph 1.1.0
typed_data 1.1.6
watcher 0.9.7+10
yaml 2.1.15
Dev dependencies
build_runner ^1.0.0