built_redux_thunk 0.5.1

  • README.md
  • Installing
  • Versions
  • 62

Thunks

By adding the thunkMiddleware to any of your built_redux stores, any action dispatched that's payload meets the typedef signature dynamic thunk(MiddlewareApi api) will be called.

Example

Create a function that returns a thunk configured with an url, that dispatches an action (onRequestResolved) in async code:

// api's type is inferred
Thunk<TestCounter, TestCounterBuilder, TestCounterActions> httpRequestThunk(String url) => (api) {
  // call the web server asynchronously.
  HttpRequest.getString(url)
      .then(api.actions.onRequestResolved);
};

Add an thunk dispatcher to your ReduxActions:

abstract class CounterActions extends ReduxActions {
  ActionDispatcher<Thunk<Counter, CounterBuilder, CounterActions>> thunkDispatcher;
  ActionDispatcher<String> onRequestResolved;

  // factory to create on instance of the generated implementation of CounterActions
  CounterActions._();
  factory CounterActions() => new _$CounterActions();
}

The action with Thunk isn't mapped to a reducer.

Register the Thunk middleware:

var store = new Store<Counter, CounterBuilder, CounterActions>(
  createReducer(),
  new Counter(),
  new CounterActions(),
  middleware: <Middleware<TestCounter, TestCounterBuilder, TestCounterActions>>[
    thunkMiddleware
  ],
);

Dispatch the thunk

store.actions.thunkDispatcher(httpRquestThunk('http://example.com/'));

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  built_redux_thunk: ^0.5.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:built_redux_thunk/built_redux_thunk.dart';
  
Version Uploaded Documentation Archive
0.5.1 Aug 7, 2018 Go to the documentation of built_redux_thunk 0.5.1 Download built_redux_thunk 0.5.1 archive
0.5.0 Jul 14, 2018 Go to the documentation of built_redux_thunk 0.5.0 Download built_redux_thunk 0.5.0 archive
0.4.0 Oct 22, 2017 Go to the documentation of built_redux_thunk 0.4.0 Download built_redux_thunk 0.4.0 archive
0.3.0 Oct 13, 2017 Go to the documentation of built_redux_thunk 0.3.0 Download built_redux_thunk 0.3.0 archive
0.2.0 Oct 5, 2017 Go to the documentation of built_redux_thunk 0.2.0 Download built_redux_thunk 0.2.0 archive
0.1.0 Sep 27, 2017 Go to the documentation of built_redux_thunk 0.1.0 Download built_redux_thunk 0.1.0 archive
0.0.1 Aug 29, 2017 Go to the documentation of built_redux_thunk 0.0.1 Download built_redux_thunk 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
51
Health:
Code health derived from static analysis. [more]
90
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
50
Overall:
Weighted score of the above. [more]
62
Learn more about scoring.

We analyzed this package on Dec 5, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.1.0
  • pana: 0.12.7

Platforms

Detected platforms: Flutter, web, other

No platform restriction found in primary library package:built_redux_thunk/built_redux_thunk.dart.

Health issues and suggestions

Document public APIs (-10 points)

3 out of 3 API elements (library, class, field or method) have no adequate dartdoc content. Good documentation improves code readability and discoverability through search.

Maintenance issues and suggestions

Maintain CHANGELOG.md. (-20 points)

Changelog entries help clients to follow the progress in your code.

The description is too short. (-20 points)

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use built_redux_thunk.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev <3.0.0
built_redux >=6.1.1 <8.0.0 7.5.0
built_value >=4.1.0 <7.0.0 6.1.6
Transitive dependencies
analyzer 0.32.6 0.34.0
args 1.5.1
async 2.0.8
boolean_selector 1.0.4
build 0.12.8 1.0.1
charcode 1.1.2
collection 1.14.11
convert 2.0.2
crypto 2.0.6
csslib 0.14.6
dart_style 1.1.3 1.2.1
fixnum 0.10.9
front_end 0.1.4+2 0.1.7
glob 1.1.7
html 0.13.3+3
http 0.12.0
http_multi_server 2.0.5
http_parser 3.1.3
io 0.3.3
js 0.6.1+1
json_rpc_2 2.0.9
kernel 0.3.4+2 0.3.7
logging 0.11.3+2
matcher 0.12.3+1 0.12.4
meta 1.1.6
mime 0.9.6+2
multi_server_socket 1.0.2
node_preamble 1.4.4
package_config 1.0.5
package_resolver 1.0.6
path 1.6.2
plugin 0.2.0+3
pool 1.3.6
pub_semver 1.4.2
quiver 2.0.1
shelf 0.7.3+3
shelf_packages_handler 1.0.4
shelf_static 0.2.8
shelf_web_socket 0.2.2+4
source_map_stack_trace 1.1.5
source_maps 0.10.8
source_span 1.4.1
stack_trace 1.9.3
stream_channel 1.6.8
string_scanner 1.0.4
term_glyph 1.0.1
test_api 0.2.1
test_core 0.2.0+1
typed_data 1.1.6
utf 0.9.0+5
vm_service_client 0.2.6
watcher 0.9.7+10
web_socket_channel 1.0.9
yaml 2.1.15
Dev dependencies
build_runner ^0.10.0
build_test ^0.10.0
build_web_compilers ^0.4.0
built_collection ^3.0.0 4.1.0
built_value_generator ^6.0.0
source_gen ^0.9.0 0.9.1+3
test ^1.0.0 1.5.1+1