bwu_utils 0.1.3

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 0

BWU_Utils

Star this Repo Pub Package Build Status Coverage Status

Just a collection of functions and classes I want to reuse in different other packages.

0.1.3

  • widen quiver dependency constraint
  • strong-mode and linter fixes

0.1.2

  • widen quiver dependency constraint

0.1.1

  • add .analysis_options (enable strong-mode)
  • minor strong-mode fixes
  • update grinder dependency constraint

0.1.0

  • merged bwu_utils_server, bwu_utils_browser
  • added Grinder tasks
  • renamed parseIntFromStringWithUnit in browser.parse_int to parseIntDropUnit
  • migrate tests to test package
  • add travis support

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  bwu_utils: ^0.1.3

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:bwu_utils/bwu_utils.dart';
  
Version Uploaded Documentation Archive
0.1.3 Dec 7, 2016 Go to the documentation of bwu_utils 0.1.3 Download bwu_utils 0.1.3 archive
0.1.2 Jun 14, 2016 Go to the documentation of bwu_utils 0.1.2 Download bwu_utils 0.1.2 archive
0.1.1 Jan 4, 2016 Go to the documentation of bwu_utils 0.1.1 Download bwu_utils 0.1.1 archive
0.1.0 Jul 14, 2015 Go to the documentation of bwu_utils 0.1.0 Download bwu_utils 0.1.0 archive
0.0.2 Jun 18, 2014 Go to the documentation of bwu_utils 0.0.2 Download bwu_utils 0.0.2 archive
0.0.1 Jun 16, 2014 Go to the documentation of bwu_utils 0.0.1 Download bwu_utils 0.0.1 archive
0.1.0-dev.3 Jun 4, 2015 Go to the documentation of bwu_utils 0.1.0-dev.3 Download bwu_utils 0.1.0-dev.3 archive
0.1.0-dev.2 May 30, 2015 Go to the documentation of bwu_utils 0.1.0-dev.2 Download bwu_utils 0.1.0-dev.2 archive
0.1.0-dev.1 Mar 22, 2015 Go to the documentation of bwu_utils 0.1.0-dev.1 Download bwu_utils 0.1.0-dev.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Maintenance issues and suggestions

Running dartdoc failed. (-10 points)

Make sure dartdoc runs without any issues.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.9.0 <2.0.0