bytes 0.3.0

  • Installing
  • Versions
  • 0


A library for working with bytes, inspired by Go's bytes package.


v0.3.0 (2018-01-31)

  • Removed copy property from buffer.
  • Support Strong Mode

v0.2.0 (2016-12-04)

  • Separated into different libs.
  • Buffer is no longer a Reader.
  • Created BufferReader.

v0.1.0 (2016-12-04)

  • Initial version

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  bytes: ^0.3.0

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:bytes/bytes.dart';
Version Uploaded Documentation Archive
0.3.0 Jan 31, 2018 Go to the documentation of bytes 0.3.0 Download bytes 0.3.0 archive
0.2.0 Dec 4, 2016 Go to the documentation of bytes 0.2.0 Download bytes 0.2.0 archive
0.1.0 Dec 4, 2016 Go to the documentation of bytes 0.1.0 Download bytes 0.1.0 archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see

Maintenance issues and suggestions

Running dartdoc failed. (-10 points)

Make sure dartdoc runs without any issues.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.0.0 <2.0.0